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1.Dashboard
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1.1. Mobile IN Punches For approval in Attendance Dashboard

“Mobile IN Punches For approval” option provided in Attendance -> Total No. of Employee(s), as shown
in below figure:

Figure 1

New option “Mobile IN Punches For approval” provided in Total No. of Employee(s). It will display the
pending Mobile In Punches for approval.
Pending “Employee list” will be displayed after clicking on count.
“Employee List” is now also available in existing options i.e. IN (Punch IN for Today), Out (Punch Out for
Today) and Available (Punch Out not done) and user can export the same.
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1.2. Remark and Employee List in Attendance Dashboard

Remark and Employee List provided in Attendance -> Shift Wise Employee Count (Today/Tomorrow), as
shown in below figure:

Figure 2

“Remark of Shift definition” will be displayed beside Shift Code in Shift Wise Employee Count
(Today/Tomorrow). After mouse hover on remark, full remark will be display.
After clicking on count, employee list will be display with Employee Code and Employee Name and user
can export the same.

1.3. Info icon in Attendance Dashboard

“Info” icon provided in Attendance -> Top 10 Employees having Latemarks (Current month), as shown in
below figure:

Figure 3

In Top 10 Employees having Latemarks (Current month), new "info” icon provided beside name of the
employee. It will show Attendance Workflow first approver (Primary) name.
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2.Admin
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2.1. Company Name Filter in Manage User Profile

Company Name filter provided in User Management -> Manage User Profile, as shown in below figure:

Figure 4

“Company Name” Filter provided in Manage User Profile, Based on Company selection data will be
display.
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2.2. Additional Filter Provided for Leave and Swipe Request

Additional Filter provided for Leave and Swipe request inWorkflow -> Update Pending Applications, as
shown in below figure:

Figure 5

In Leave Application Module, provided All/OD/Leave Filter in App Type dropdown. Selecting "Leave"
from this dropdown will display only leave applications.

Figure 6

In Swipe Request Module, Provided All/Swipe Request/ Shift Change Request Filter in App Type
dropdown. Selecting "Swipe Request" from this dropdown will display only Swipe applications.
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2.3. Preview option provided in Tax Declaration Approvals

Preview option provided for PDF Attached document in Approvals -> Tax Declaration, as shown in below
figure:

Figure 7

Approver can View/Download PDF attached by employee while approve tax declaration record by
clicking on View Doc. option.

2.4. New setup provided in Mobile HR

New setup provided "Show fence allocated to only me" in Site Admin -> Standard Settings -> Mobile-HR.

Figure 8

By using this setup, only assigned fence will be available to employee for selection. User can assign fence
to employee from Time -> Define -> Shift Definition -> Utility -> Define Fence -> Assign Fence.
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Figure 9

Assigned fence to employee will be available for selection while Clock In/Out fromMobile HR, as shown
in below figure:

Figure 10
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2.5. Newmacros provided in Email Notification Config

Todays macro added in Site Admin -> Email Notification Config, as shown in below figure:

Figure 11

In Field Name new macros are added in Email Notification Config. By using these macros user can send
list of employee in email notification.
1. Date of Birth_Todays - Employee list having birth day on current day will send in email notification

as per “Send To” option selected. In Condition Filter it display “AND
MASTER1.DO_BIRTH_TODAY=@TODAY”.

2. Date Joined_Todays - Employee list having join date on current day will send in email notification as
per “Send To” option selected.

3. Date of Confirmation_Todays - Employee list having confirmation day on current day will send in
email notification.

4. Last Inc.Date_Todays - Employee list having last Inc.Date day on current day will send in email
notification.

5. Group Joining Date_Todays- Employee list having group Joining on current day will send in email
notification.

6. Probation Date_Todays - Employee list having probation day on current day will send in email
notification.

7. Resign Offer Date_Todays - Employee list having resign offer on current day will send in email
notification.

8. Resignation Date_Todays - Employee list having last working on current day will send in email
notification.

By using this macro user can send list of employee in email for current date birthday, join date, confirm
date, probation, resign offer, resignation date .
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2.6. Muster Fields provided in Email Notification Config

Add Muster Field option provided next to Field Name in Site Admin -> Email Notification Config, as
shown in below figure:

Figure 12

After clicking on “Add Muster Field”, “Todays Muster Data” and “Yesterday Muster Data” radio buttons
are available for selection. Tot Hrs, User DA Type 1, Ot Hrs, Late Hrs, Early Hrs etc. muster macros are
provided.
Todays Muster Data - Current date muster data as per macro selection will be send as per “Send to”
setup.
Yesterday Muster Data - Previous date muster data as per macro selection will be send as per “Send to”
setup.
After clicking on “Add Muster Field” Muster fields macros are available for selection.
After selection of macros, selected macros muster data will be send in email as per setup.
E.g.
To send todays Absent employee list, condition will be “AND MASTER3.DAType1='ABS' And
MASTER3.Dt=@TODAY”.
To send Effective hours greater than 5, condition will be “ AND MASTER3.EffectiveHrs>5 And
MASTER3.Dt=@TODAY”.
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Figure 13

2.7. New Employee Info macros provided in Email notification Config

Additional Macro related to employee information provided in Site Admin -> Email Notification Config, as
shown in below figure:

Figure 14

NewMacro’s for Email Body as listed below with description:

1. @@EmpName : This micro will show Employee Name in Email.
2. @@EmpCode : This micro will show Employee Code in Email.
3. @@DOJ : This micro will show Joining date of employee in Email.
4. @@DOB : This micro will show Date of Birth in Email.
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5. @@FNF_Date : This micro will show FNF(Left Date) Date in Email.
6. @@Resign_Date : This micro will show Last Working Date in Email.
Above macro will work only with Email Send To “Self” option i.e email will be sent to employees on there
individual email address with there details.
To send auto Email kindly create Template in Site Admin -> Email Notification Config.

2.8. User IP Address field provided inWeb Statistics Reports

”User IP” column provided in Reports -> Web Statistics -> Web Statistics List Report, as shown in below
figure:

Figure 15

IP address of user machine will be reflect in this column.
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2.9. MoodoMeter Report in Admin

“Moodo Meter Report” provided in Reports, as shown in below figure:

Figure 16

New report provided in Reports as "Moodo Meter Report". It will display the report of Moodo meter.
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3.Self Service
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3.1. Re-apply provided for Previous Employer Form16

Re-apply functionality provided for Taxation -> Previous Employer Form16, as shown in below figure:

Figure 17

If HR user rejects request of previous employer form 16 then Employee can re-apply after rejection and
submit the same.
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3.2. Widower option in Marital Status

“Widower” option provided in Edit -> Contact, as shown in below figure:

Figure 18

New option “Widower” added for Marital Status field in Contact and same will be displayed in Self
Service -> View -> Personal.
Note: Same changes done with Mobile-HR also.

3.3. Search option provided in My Documents

Search option provided in Quick Info -> My Documents, as shown in below figure:

Figure 19

“Search” option provided in Self Service, user can find document by typing initials.
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4.Leave

4.1. New setup provided in OD List Report
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New setup "Show feedback of all Managers" provided in, Outdoor Duty -> Reports HR/Manager, as
shown in below figure:

Figure 20

After opting setup user can viewManager Remark, Manager Action, Manager Code, Work Stage column
same as Leave report, as shown in below figure:

Figure 21

4.2. Allowmanager to change Leave Category setup in Leave Settings
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“Allow manager to change Leave Category” setup provided in Configuration -> Settings -> Leave
Application - General Settings, as shown in below figure:

Figure 22

New setup "Allow manager to change Leave Category" provided in Leave Settings. Now it will allow
manager to change Leave Category while approving leave application.
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5.Time

5.1. Muster Report Writer - Manager newmenu provided
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Muster Report Writer - Manager new menu provided in Attendance Reports -> Muster Report Writer -
Manager, as shown in below figure:

Figure 23

New menu provided for Approver in Attendance Reports as Muster Report Writer - Manager.
Managers are authorized to access and utilize report templates that have been created by the HR.
Managers are not allowed to create new templates or delete existing ones.

5.2. Muster Report Writer Grouping - Manager newmenu provided

Muster Report Writer Grouping - Manager new menu provided in Attendance Reports -> Muster Report
Writer Grouping - Manager, as shown in below figure:
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Figure 24

New menu provided for Approver in Attendance Reports as Muster Report Writer Grouping - Manager.
Managers are authorized to access and utilize report templates that have been created by the HR.
Managers are not allowed to create new templates or delete existing ones.

5.3. Machine namemultiple selection provided

Machine name multiple selection is provided in Attendance Reports > Reports - HR >Daily In/out report,
as shown in below figure:
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Figure 25

Previously, "Machine Name" field in the Daily In Out report only allowed selection of a single entry at a
time. Now, it will allow selection of multiple Machine Names simultaneously and based on selection data
will be displayed.

5.4. Company Name Filter Option provided

Company Name Filter Selection provided in Lock Data - Unlock Data , Mark - Revoke In-Out as X – HR,
etc…. menus as shown in below figure:
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Figure 26

Company Name Filter Selection is provided in below menus :
1.Lock Data - Unlock Data
2.Mark - Revoke In-Out as X – HR
3.MISC Utilities
4.Publish Holiday Calendar
5.Card Punch Setup
6.Weekly Off
7.Import Daily Attendance
8.Mobile Swipe Report - HR
9.Recalculation Muster
10.Muster Update – Bulk
Based on Company Name selection data will be displayed or action will be taken.

5.5. Option provided to view archive data

New setup option “Get Report From Archive Data” provided for below menu’s:

1. Time -> Attendance Reports -> Muster Report Writer
2. Time -> Attendance Reports -> Muster Report Writer Grouping
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3. Time -> Attendance Reports -> Reports-HR ->Daily InOut Detail Report
4. Time -> Attendance Reports -> Reports-HR ->Monthly Attendance Report
5. Time -> Attendance Reports -> Reports-HR ->Daily Attendance Report
6. Time -> Attendance -> My Attendance
7. Time -> Attendance -> View Attendance -Manager
8. Time -> Attendance -> View Attendance -HR
9. Admin -> Reports->Web Statistics
10. Admin -> Reports -> Log of Settings Edit-Update

Figure 27

If option is opted then it will show data as below:
1. For Muster Report Writer, Muster Report Writer Grouping, Daily InOut Detail Report, Monthly

Attendance Report and Daily Attendance Report data till 31-Mar-2023 will be displayed.
2. For Web Statistics and Log of Settings Edit-Update data till 31-Dec-2023 will be displayed.
3. If data archived through Admin -> ESS Config -> Data Archive Utility then reports for that archived

period can also be viewed with above setup.

5.6. Export to Excel provided

“Export To Excel” option provided in Attendance Report -> Muster Report Writer andMuster Report
Writer Grouping, as shown in below figure:



New Features of Spine HRMS Version 6.0.7

28

Figure 28

It will allow user to export report of selected fields and date range in excel format.

Action button provided and View button renamed to "List Data"

5.7. Assign Fence to employee option provided

Assign fence to employee option provide in Define -> Shift Definition -> Utility -> Define Fence -> Assign
Fence, as shown in below figure:
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Figure 29

With this option User can assign employeewise fence.
At Import employee wise fence page Delete, Import, Export options are provided.
User can assign fence to employee by using import option.
In import option Employee Code and Fence Name columns are available. User log is available for view
import errors.

Figure 30

Only .csv And .txt file format will be allowed to import.
In import “Delete Existing Record” option provided. By opt this option existing fence record will be
deleted and new records will be saved.
User can export existing record by using Export option.
With Delete option user can delete existing records.
Assigned Fence will be available to employee while punch frommobile by opting setup from Admin ->
Site Admin -> Mobile-HR -> Show fence allocated to only me, as shown in below figure:
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Figure 31

5.8. Data Access Control provided for Delete Reconciliation

In Attendance Utilities -> Reconciliation (Delete Reconciliation ) Data Access will work, as shown in below
figure:

Figure 32

Previously Data Access Control not working for “Delete Reconciliation”. Now Data Access Control will
work for “Delete Reconciliation”.
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5.9. New setup provided in Attendance Setting

New setup provided to calculate effective hours for Z flag in Configuration -> Attendance Settings, as
shown in below figure:

Figure 33

Previously Effective Hours were calculated for In/Out punches. Now using this setup user can calculate
effective hours for Z flag. If setup is not opted then effective hours will not calculated for Z flag.

5.10. Latemark legends in My Attendance

“Latemark” legends provided in Attendance -> My Attendance, as shown in below figure:

Figure 34

“Latemark” legends provided in My Attendance, View Attendance - Manager and View Attendance - HR.
Now user is able to view latemarks for a particular month.
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5.11. Minute Limit change for Yearly in Short Time Off Settings

Minute Limit change for Yearly in Configuration -> Short Time Off Settings -> Attendance Group Wise
Settings, as shown in below figure:

Figure 35

Yearly Minute limit increased to 9999 in Short Time Off Settings. Now user is able to set yearly limit upto
9999.

5.12. Shift change approval - Remark of Employee provided

Shift Change Request Remark is provided in Shift Change -> Approve, as shown in below figure:

Figure 36

Shift Change Approval page, managers can view remark added by employees regarding shift change
requests in the list view.
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6.Claims
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6.1. Remark column added in Expense Approve page

Remark column added in Expense -> Approve Voucher, as shown in below figure:

Figure 37

In Remark column, expense narration added by employee will be displayed. Existing label Narration is
changed to Manager Remark.

6.2. New report added in Flexi Basket

New report added in Flexi Basket Reports as "Flexi Basket Reimbursement Head Wise Report" in Reports
- HR -> Flexi Basket Reimbursement Head Wise Report, as shown in below figure:

Figure 38

Previously in Flexi Basket Report only allocated amount was getting displayed. Now in “Flexi Basket
Reimbursement Head Wise Report” Reimbursement head wise applied amount will be displayed in
report.
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6.3. Monthly balance amount display provided in Flexi Basket

Monthly Amount field is provided in Flexi Basket -> Check Request/ Approve Request, as shown in below
figure:

Figure 39

It will show value of Yearly Amount/12 for Allocate Amt., User Amt. And Balance Amt.
For e.g. If Yearly amount is 24000 then 24000/12 =2000 will be shown in Monthly Amount.

6.4. Exp. Category On Approve Voucher page filter

“Exp. Category” option provided in Expense -> Approve Voucher, as shown in below figure:

Figure 40

“Exp. Category” option provided On Approve Voucher Page filter in Search for field. Now user is able to
search Exp. Category by selecting this.
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7.PMS
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7.1. PMS Setting "Employee Report Card Setup" section provided

PMS Setting "Employee Report Card Setup" section provided in Configuration -> PMS Settings, As show
in below figure:

Figure 41

PMS Setting "Employee Report Card Setup" section provided.Employee Report Card - HR / Manager data
will be displayed based on setup opted.

Following setups are provided :
1. Show Progress bar
If Setup is opted then data will be displayed as shown in below figure:

Figure 42

2. Goal Head Category Weightage
3. If Setup is opted then data will be displayed as shown in below figure:
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Figure 43

4. KPI sectional score calculation
If Setup is opted then data will be displayed as shown in below figure:

Figure 44
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5. Training and Knowledge Upgradation needs

New Section provided as “Training List” in Employee Report Card - HR / Manager,It will show Training
needs added for Employee.

Training needs details can be updated from Appraisals -> Self , Appraisal -> By Manager , Appraisal -> By
HR in Add Training Request tab, as shown in below figure:

Figure 45

If Setup is opted then data will be displayed as shown in below figure:

Figure 46
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6. Potential Assessments
New Section provided as “Potential Assessments” in Employee Report Card - HR / Manager,It will show
Promotion Information added for Employee.

Promotion Information update from Appraisal -> By Manager , Appraisal -> By HR in Promotion
Information tab, as shown in below figure:

Figure 47

If Setup is opted then data will be displayed as shown in below figure:

Figure 48
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7.2. Utility - Past Appraisal Info utility provided (Key Based Feature)

Utility - Past Appraisal Info utility is provided in Scorecard -> Employee Report Card - HR / Manager, as
shown in below figure:

Figure 49

Employee Report Card - HR / Manager Utility provided "Past AppraisalInfo import" in which HR/Manager
can import Appraisal Info for employee.

Figure 50

PMS Setting "Employee Report Card Setup" section “Show past appraisal data” setup provided. If setup
opted then in Employee Report Card - HR / Manager "Past Appraisal Info" Section will be displayed.

Figure 51
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Uploaded details will be displayed in "Past Appraisal Info" Section as shown in below figure:

Figure 52

7.3. Rating Slab new PMS Settings added (Key Based Feature)

Rating Slab new PMS Settings added in Configuration -> PMS Settings, As show in below figure:

Figure 53

“Rating Slab Setup” tab is added in PMS Settings. User will add different rating slab and provide legend
and remark for the same.
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Figure 54

In PMS Setting "Employee Report Card Setup" section, “Show slab info with rating” setup is provided. If
this setup is opted then in Approver Rating section will be displayed in Employee Report Card - HR /
Manager.
Approver Rating will show Total score of KRA+Goal, Slab wise rating based on Total score add by each
level managers .

Based on Slabs defined, Employee Report Card - HR / Manager -> “Approver Rating” Section data will be
displayed as shown in below figure:
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Figure 55

7.4. Update Remark Utility provided (Key Based Feature)

Update Remark Utility is provided in Scorecard -> Employee Report Card - HR / Manager, as shown in
below figure:

Figure 56

Employee Report Card - HR / Manager-> Update Remark provided to add Remark for employee.
Levelwise Final rating and remark will be displayed.

Final Assessment Remark section will be displayed based on setup opted in PMS Setting "Employee
Report Card Setup" section “Show final assessment remark and rating” as shown in below figure:
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Figure 57

In HR Remark - Utility -> Update Remark, HR can update remark based on Slab wise Rating and
dropdown selection will be displayed for ratings. Also HOD Level rating will be displayed to HR.

Figure 58

Updated remark by HR will be displayed in "Final Assessment Remarks by Top Management" section as
shown in below figure:
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Figure 59

Manager Remark section will be displayed based on setup opted in PMS Setting "Employee Report Card
Setup" section “Show Manager Remark” as shown in below figure:

Figure 60

Manager Remark - Based on define slab Legends will be displayed to manager with read only format as
shown in below figure :
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Figure 61

Updated remark by Manager will be displayed in "Manager Remark" section.Manager can view only
update remark by themselves , as shown in below figure:

Figure 62
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7.5. Correction factor processing for HOD1 to HOD5 added (Key Based
Feature)

Correction factor processing for HOD1 to HOD5 added in Configuration -> PMS Settings -> General
Setting, as show in below figure:

Figure 63

In General Setting Correction factor processing/Calculate HR Rating : HOD1 to HOD5 is provided.
Based on defined formula Approval Rating will be displayed In Employee Report Card HR/Manager and
Correction Factor as shown in below figure:

Figure 64
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7.6. Changes in Copy approver rating (Key Based Feature)

New option provided to copy approver rating in Scorecard -> Normalization -> Utility -> Copy Approver
Rating, as given in below figure:

Figure 65

It will allow to copy approver rating from higher to lower level when current rating is 0. It will copy for
only those levels where approvers are the same.

Figure 66

For Eg. If 4 Approver levels are defined in PMS workflow and same approver(Code:1001) is assigned at
Level1, Level2 and Level3 then "Copy Approver Rating" will allow to copy Level 3 value to Level2 and
Level1 after appraisal submitted by Approver(Code:1001).
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8.Mobile HR
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8.1. MoodoMeter Provided in Mobile HR

Moodo Meter provided in Dashboard, as shown in below figure:

Figure 67

Moodo Meter is provided in Mobile HR, allowing employees to log their mood mobil
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8.2. City Search Option In Mobile HR

Provided Search option for City while apply expense voucher in Applications -> Expense -> Add Expense,
as shown in below figure:

Figure 68

While applying Expense voucher frommobile, Search option provided for City field.
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8.3. In-Out punches displayed in My Attendance

In-Out punches displayed in View -> My Attendance, as shown in below figure:

Figure 69

In My Attendance In-Out punches detail will be displayed after clicking on date as per HRMS.
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8.4. In My Attendance portion total displayed

In View -> My Attendance, portion total will be displayed, as shown in below figure:

Figure 70

In My Attendance Portion column total count will be displayed at bottom.
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8.5. Select All checkbox provided for final submit Expense voucher

“Select All” checkbox option provided while final submit in Application -> Expense -> Add Expense, as
shown in below figure:

Figure 71

While doing final submission of expense voucher, select all checkbox is provided. User can select all
added records by using “Select All” checkbox.
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8.6. Leave Cancellationmenu provided

Leave Cancellation menu provided in Mobile HR as shown in below figure:

Figure 72

Same as HRMS “Leave Cancellation” menu in mobile HRMS will allow employee to add cancellation
request for approved leave application of past 6 months.

Figure 73
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8.7. Note provided for Swipe, OD, CO+

Note for OD, CO+ and Swipe is provided in Mobile HRMS version same as HRMS, as shown in below
figure:

If note is available in HRMS -> Leave -> Configuration -> Leave Notes and Time -> Configuration -> Swipe
Notes then same will be visible in OD/CO+/Swipe ->Apply page.

On click of Note:(!) symbol Note will display.

Figure 74


	1.Dashboard
	1.1. Mobile IN Punches For approval in Attendance Dash
	1.2.Remark and Employee List in Attendance Dashboard
	1.3. Info icon in Attendance Dashboard
	2.Admin
	2.1.Company Name Filter in Manage User Profile
	2.2.Additional Filter Provided for Leave and Swipe Req
	2.3.Preview option provided in Tax Declaration Approva
	2.4.New setup provided in Mobile HR
	2.5.New macros provided in Email Notification Config
	2.6.Muster Fields provided in Email Notification Confi
	2.7.New Employee Info macros provided in Email notific
	2.8.User IP Address field provided in Web Statistics R
	2.9.Moodo Meter Report in Admin
	3.Self Service
	3.1.Re-apply provided for Previous Employer Form16
	3.2.Widower option in Marital Status
	3.3.Search option provided in My Documents
	4.Leave
	4.1.New setup provided in OD List Report
	4.2.Allow manager to change Leave Category setup in Le
	5.Time
	5.1.Muster Report Writer - Manager new menu provided
	5.2.Muster Report Writer Grouping - Manager new menu p
	5.3.Machine name multiple selection provided
	5.4.Company Name Filter Option provided
	5.5.Option provided to view archive data
	5.6.Export to Excel provided
	5.7.Assign Fence to employee option provided
	5.8.Data Access Control provided for Delete Reconcilia
	5.9.New setup provided in Attendance Setting
	5.10.Latemark legends in My Attendance
	5.11.Minute Limit change for Yearly in Short Time Off S
	5.12.Shift change approval - Remark of Employee provide
	6.Claims
	6.1.Remark column added in Expense Approve page
	6.2.New report added in Flexi Basket
	6.3.Monthly balance amount display provided in Flexi B
	6.4.Exp. Category On Approve Voucher page filter
	7.PMS
	7.1.PMS Setting "Employee Report Card Setup" section p
	7.2.Utility - Past Appraisal Info utility provided (Ke
	7.3.Rating Slab new PMS Settings added (Key Based Feat
	7.4.Update Remark Utility provided (Key Based Feature)
	7.5.Correction factor processing for HOD1 to HOD5 adde
	7.6.Changes in Copy approver rating (Key Based Feature
	8.Mobile HR
	8.1.Moodo Meter Provided in Mobile HR
	8.2.City Search Option In Mobile HR
	8.3.In-Out punches displayed in My Attendance
	8.4.In My Attendance portion total displayed
	8.5.Select All checkbox provided for final submit Expe
	8.6.Leave Cancellation menu provided
	8.7.Note provided for Swipe, OD, CO+

