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New Features of Spine HRMS Version 6.0.3

1. Dashboard

1.1. Main Dashboard - Notification Block Changes

On Dashboard Notification block changes has provided, as shown in below Figure :

Figure 1
I. Maximum 15 records will be displayed.
II. If Notification block contains more than 15 records then View more option will displayed. It will

displayed all records on View more.

1.2. Changes in Leave Dashboard Top 10 Leave Takers Block

Changes are done in Top 10 Leave Takers Block in Dashboard -> Leave Dashboard, as shown in below
Figure:
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Figure 2

I. For this block Title is changed to ‘Top 10 Leave Takers (Current vs. Previous Month)’
II. Previous Month column is added for this block.
III. It will display Top 10 Leave Takers in current month with Previous Month Leaves taken.
(Note : Here count of leaves considered as all leave types (PL,SL,etc).)

1.3. Changes in attendance Dashboard-Top 10 Employees having
Late marks (Current Month) Block

Changes are done in Top 10 Employees having Late marks (Current Month) block in Dashboard ->
Attendance and Attendance -> Dashboard-Manager, as shown in Below Figure:

Figure 3

I. For this block Title renamed as "Top 10 Employees having Late marks (Current vs. Previous Month)
II. Previous Month column is added for this block.
III. It will display Top 10 employee having late mark in current month with Previous Month Late mark.

1.4. Total No. of Employees In/Out count provided in Attendance
Dashboard

‘Total No. Of Employees attendance In/out count’ is provided in Admin -> Dashboard ->Attendance and
Time -> Attendance -> Dashboard-Manager, as shown in below Figure :
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Figure 4

I. It will display "In/Out/Available"' count for the punch done today.
II. In count will display Punch IN done today (12:00 AM to 11:59 PM) by employee.
III. Out count will display Punch OUT done today (12:00 AM to 11:59 PM) by employee.
IV. Available count will display for employee IN punch done but OUT punch not done today.
Note : This block will display count purely on I/O Flag. It will not consider any shift cut off setup.

1.5. Recruitment Dashboard Enhancement

Vacancy data will be displayed on top in Admin -> Dashboard -> Recruitment, as shown in Below Figure:

Figure 5

It will be as per vacancy status(open, close, all) as shown in figure.
Following data will be display by default as per vacancy status "Open"
I. One Filter given to filter data, data will be filter as per Vacancy status Open/Closed/ All
II. Job(s) count will be display only No. of approved vacancy.

http://192.168.9.101/zentao/testtask-view-500.html
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III. Good Profiles shows percentages which will be calculate = (no. of Shortlisted candidate by / total
applies)*100,

IV. Recruitment Funnel display bar of Applied, Shortlisted by HR, Shortlisted by Requester, Offers, Joins
where Applied calculate = (total applies/ total applied+ total Shortlisted by HR + total Shortlisted by
Requester + total Offers + total Joins)*100. In Recruitment funnel bar other option will be calculate
same as total applies.

Note : For above calculation Applies, Shortlisted candidate by HR, Shortlisted candidate by Requester,
Offers, Joins count fetch from Vacancy summary tab of Vacancies > Check request.

1.6. Dashboard Filter Enhancement - Attendance Dashboard

Company filter selection is provided in In Admin > Dashboard > Attendance, as shown in below fig:

Figure 6

Using Company Name Filter user can filter data company wise.

1.7. Dashboard Filter enhancement - Leave Dashboard

Company Filter is provided in Admin -> Dashboard -> Leave, shown in below figure:
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Figure 7

Now provided Company Filter to filter the data.

1.8. HR Dashboard Filter enhancement - Workforce Demographics tab

CC Masters filter given to filter data in Admin -> Dashboard -> HR - Workforce Demographics tab, as
shown in below fig:

Figure 8

User can Filter data using newly provided filter.

1.9. Welcome New Joinee Block Changes

Next and Previous buttons are provided in New Joinee Block, as shown in Below figure:
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Figure 9

By using Next button and Previous button, all Employees display In welcome New Joinee Block from Past
Group Joining Date till Current date.

1.10. New Column added in Attendance Dashboard

New Column “Total WO” is added in Employee Count Analysis Block in Dashboard >Attendance
Dashboard, as shown in below figure:

Figure 10

Total WO column is added in Employee Count Analysis Block .It shows number of employee on weekly
off.
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1.11. Recruitment Funnel Changes

Changes are done in Recruitment Funnel on Dashboard in Dashboard->Recruitment, as shown in Below
Figure:

Figure 11

Details of candidates who are marked as Not Joined after doing pre-join entry will now reflect in
Recruitment Funnel.

1.12. Attrition Dashboard

Attrition Dashboard is provided in Dashboard->Attrition, as shown in Below Figure:

Figure 12

Below Details are displayed on Dashboard:

1. Attrition Analysis Report and Graph (Month wise)

Month wise Details will be displayed in this block,as shown in Below Figure:
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Figure 13

I. Joined: Number of Employee(s) joined in mentioned month
II. Separation: Number of Employee(s) left in mentioned month
III. Closing: Opening+Joined-Separation for mentioned month
IV. Attrition this month: Separation/[((opening+closing)/2)%]
V. Attrition Cumulitive: Previous month cumulitive + ‘Attrition this Month’ for mentioned month.

2. Attrition Analysis Report and Graph (Year wise)

Year wise Details will be displayed in this block,as shown in Below Figure:
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Figure 14

I. Opening: Current Employee count at Start of mentioned Year
II. Joined: Number of Employee(s) joined in mentioned Year
III. Separation: Number of Employee(s) left in mentioned Year
IV. Closing: Opening+Joined-Separation for mentioned Year
V. Attrition this Year: Separation/[((opening+closing)/2)%]

Attrition Dashboard Reports will be available for employee with HR role.

1.13. ‘Don’t showme this again’ option provided for Vaccine Details

‘Don’t showme this again‘ option is provided in Covid Vaccine Details on Dashboard Lite, as shown in
Below Figure:

Figure 15
If user has entered both Dose 1 and Dose 2 details and selected ‘Don’t show me this again.’ then covid
vaccine detail block not displayed on Dashboard lite after next login.
Employee can see his filled Covid vaccine detail in Quick Link option "My Covid Vaccine Detail" .
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1.14. Moodometer Provided

Using this Employee can Record their Mood on daily basis.
New setup provided in Admin -> Site Admin -> Standard Settings ,as shown in Below figure:

Figure 16

If this setup is opted then moodo meter will link will display to employees on dashboard header, as
shown in below figure:

Figure 17

On click of Moodo meter link one form to enter mood will display, as shown in below figure:
There are 5 Mood Type available as follow:
i.Excellent
ii.Happy
iii.Average
iv.Bad
v.Worst.
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Figure 18

Employee can capture their mood only once in a day. Once mood mark for a day it will show “Your Mood
for the day is <Captured Mood Type> as shown in below figure:

Figure 19
Captured mood data analysis will be shown to HR in Admin --> Dashboard--> Moodo Meter menu.

Following Graph/Chart representation provided for Moodo meter:

i. Date/Month wise Moodo: Date or month wise Mood count will be shown in the form of chart
representation and records of count and percentage will be shown in tabular format as shown in
below figure:
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Figure 20

ii. Date Wise Moodo Meter: Date wise Mood count will be shown in the form of tabular
representation and records of count and percentage will be shown in tabular format as shown in
below figure:

Figure 21

iii. Month wise (Percentage/Count): Month wise total captured Mood count or percentage will be
displayed, as given in below figure(s):

Figure 22
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Figure 23

iv. Monthwise(Last 6 month): Last 6 month mood percentage analysis will be reflect in the form of
chart, as shown in below figure:

Figure 24
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2. Admin

2.1. Asset Entry Import

Assets Entry Import option is given for Multiple Asset Entries in HR Activities -> Assets Entry, as shown in
below figure:

Figure 25

User can import multiple asset from here.

2.2. Employee track is provided for HR

Employee Track is provided in HR Activities -> Employee Track for employee having HR web role, as
shown in below Figure :

Figure 26
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This is same as Manager desk available for Managers.It will display Employee details i.e Employment Info,
contact info, Qualification,Attendance etc.

2.3. Dashboard Lite Setting

Some Changes are done in Site Admin -> Std. Settings -> Dashboard Lite Setting, as shown in below
figure:

Figure 27

In Dashboard lite settings, shortcut link is given with name “Add Dashboard Lite Notes” for Dashboard
notes menu on the top of the settings.
When pin to start option opted then Another shortcut link activated with Name “Add to Dashboard Lite”
for dashboard lite menus.

2.4. Mobile No. Length setup is provided for Contact Details

“Allow Mobile No. [ X ] length for edit profile” setup is provided in Site Admin -> Standard Setting->Self
Service Settings , as shown in below Figure:

Figure 28

It will display Number from 7 to 15 for selection.As per selected length of mobile number it will allow
(validate) to enter Mobile No. in Self Service -> Edit -> Contacts and for approval in Admin -> Approval ->
Contact/Statutory.
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2.5. Visa Module for Onboard formalities

Visa Module added for Onboard in Site Admin -> Other Web Settings - > Onboard formalities settings, as
shown in below figure:

Figure 29

Now Employee and Family Visa Details can be filled while filling onboard Form.

2.6. Work anniversary display on years completion setup provided

"Show work anniversary only with completion of years" option is provided in Standard Setting -> Other
Web Setting , as shown in below Figure :

Figure 30

Multiple No. of years can be entered in this setup by comma separator. For e.g. 1,5,10
Work anniversary will display for employee as per no. of completed years mentioned in setup.
If in setup no. of years kept as blank then it will display all employees work anniversary completed today.
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2.7. File Uploading Size Setup is provided for all modules.

File upload size setup is provided in Site Admin -> Std. Setting ->Others, as shown in below Figure :

Figure 31

I. Allow File Uploading upto [1-10] MB : 1 to 10 MB can be selected to upload file size. Fore.g. 5 MB
kept in setup then file size can be uploaded till 5 mb. Impact of this has provided in all modules, for
e.g. Expense Voucher document attachment.

II. Web.Config Max Request Length and Max Allowed Content Length : User can enter Max request
Length with min value 4096kb (4mb) & Max value 512000kb (500MB) and Max Allowed

Content Length with min value 30000000 bytes (28.6 MB) & 524288000 bytes (500 MB).
Above setup will be saved in Web.config. After saving setup, re-login to get impact of it.

2.8. Payslip Display for PayrollNX database

Payslip display provided in Payroll NX database, Same as Desktop Database. Setting is provided in Site
Admin -> Std. Settings -> Tax Projection and Payslip settings as shown in below Figure:

Figure 32

As per above setup, Payslip will be displayed in Self Service -> Salary -> Payslip as shown in below Figure:
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Figure 33

2.9. Passport and Visa expiry notificationmail for Family Members

Some Changes are done in Site Admin --> Std. Settings -> Reminder Email to Employee/ HR,as shown in
below Figure:

Figure 34
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Figure 35

Now Passport and Visa expiry notification Email will be send to HR and Employee for Family Members
also.

2.10. QID Expiry notification mail (GCC license)

QID Expiry Mail Setting is provided in Site Admin -> Standard Settings -> Reminder Email to Employee/HR ,
as shown in below Figure:

Figure 36
If this setup is opted then Email will get sent to HR and Employee whose Qatar ID is going to expire.

2.11. Fund Raiser Module for PM Cares Fund

Fund Raiser Module is provided for PM Care Fund Contribution where employee can contribute fund
based on no of days.
Setup is provided in Site Admin -> Standard Setting -> Setting Type : Covid Care, as shown in below
Figure :
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Figure 37

I. Show PM Care fund contribution Page after login : If this is opted then PM care fund page will
display after login. Note : User can opt either Dashboard Lite or PM Care fund.

II. Add Photo : Photo file can be attached here which will display on PM Cares fund contribution page.
III. Description : Content can be added to display on PM Cares fund contribution page.
IV. Do not allow to edit details after [] of every month : It will display 10 to 31 numbers (as days). PM

cares fund page will be allowed till the selected day for current month.

If “Show PM Care fund contribution Page after login”opted then after login Page PM Cares Fund
contribution will be displayed with 2 options :
I. Yes i will donate : if this is opted then days can be selected for month employee wants to

contribute.
II. No : If this is opted then Remark will be mandatory for submit the form.
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Figure 38

I. Report is also provided in Admin ->HR Activities -> PM CARES Fund Report for PM fund contribution
done by employee. It will display Emp code, Emp name, Month and year , No of days and Remark.

Figure 39

1. This days will be processed while generating salary. To import days below working is provided in
Payroll :

I. Add at pay time variable in column master and upload the contributed days while processing salary
using Fund Raiser Utility option in sub-process drop-down.
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Figure 40

II. Execute -> EnterAt pay time column code to transfer days in this column.
III. In Utilties -> Misc Utilities -> Fund Raiser utility is provided where user can map the deduction head

for which monthly amount deducted will be posted in Investment detail under section 80G.

Figure 41

(Note : Add deduction column code as Formula which contain those upload days in At Pay Time column
code.)
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2.12. Covid Vaccine Details

In Admin > Site Admin, Setting "PM CARES Fund" is renamed to "Covid Care".
New setup provided in Site Admin -> Covid Care, as shown in below Figure:

Figure 42

New setup "Show Vaccine Details" is provided with "Show PM CARES Fund Contribution page after
Login" in Covid care. Both these setup can be opted at same time.
Dashboard Lite setup and Covid Care setup is not allowed to opt at the same time.
If this setup is opted then details will be displayed after login as shown in below Figure :

Figure 43

Dose 1 and Dose 2 Vaccine Name and Certificate can be attached from here.
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2.13. Date for vaccine Dose provided in Covid vaccine details

If Show Vaccine Details option opted in Admin -> Standard Setting-> Covid Care setting then after login
to HRMS, Vaccination details will also display “Date field for both Dose 1 and Dose 2”, as shown in below
Figure:

Figure 44

It is provided to select Date on which Dose 1/ Dose 2 has taken by Employee.

2.14. Employee Feedback in QAS report for Exit Route

“Employee QAS and Employee Feedback” option is provided in Admin -> QAS -> QAS Reports-> QAS
detail reports for Exit Route QAS, as shown in below Figure :

Figure 45
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I. Employee QAS : Existing QAS report which will display data for exit QAS filled by Manager for
approved Exit Route application.

II. Employee Feedback : It will display data for employee feedback filled by employee while applying
Resignation request.

2.15. Employee Rating Field provided in Question Bank

Rating Field is provided in QAS - > Question Bank as shown in below figure:

Figure 46

'Show Rating for Interview Round QAS' setup is provided in Recruitment Settings.If this is opted then
QAS > Question Bank will show a Rating field for each answer (Maximum 5 digits, Decimal Not
allowed).Rating Facility will be available only for Recruitment QAS.

2.16. Virtual ID provided in Mobile HRMS

In Spine HRMS, new Setting Type "Mobile-HR" is provided in Admin -> Site Admin -> Std. Setting, as
shown in below Figure:
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Figure 47

It will display Mobile Attendance Settings and Virtual ID Setup.
I. Mobile Attendance Setting available in Time ->Configuration -> Attendance Setting is shifted to new

Setting Type : Mobile -HR in Admin -> Std Setting.
II. Virtual ID Setup have following options to display on ID Card, as shown in below Figure:

Company Logo,Company Name,Employee Photo,Employee Code and Name, Employee
Gender,Employee Blood group,Employee Department,Employee Designation,Company
Address,Company Contact No. and Email.

Figure 48

III. Virtual ID is provided for Mobile HRMS. It will display Employee and Company details on Virtual ID
based on setup .
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2.17. New Setting Type: User Data Management (Policy Documents)

In standard Setting New Setting Type: User Data Management is provided in Admin -> Standard Setting
-> User Template Management as shown in below Figure:

Figure 49

I. In standard Setting New Setting Type: User Data Management is provided.
II. Module :Policy Documents (HTML Template) is provided.
III. User can add/Delete/Download Template from here.
IV. Uploaded template file will be saved to Userdata > config.
V. Uploaded files will be shown in HR Activities > Policy Documents > Corporate Guideline

2.18. New Setting Type: User Data Management (Recruitment Letter
Writing)

In standard Setting New Setting Type: User Data Management is provided in Admin -> Standard Setting
-> User Template Management as shown in below Figure:

Figure 50
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I. In standard Setting New Setting Type: User Data Management is provided.
II. Module :Recruitment Letter Writing(HTML Template) dropdown is provided.
III. User can add/Delete/Download Template from here.
IV. Uploaded template file will be saved to UserData > LetterTemplate.
V. Uploaded files will be shown in Recruitment > Appointments > Letter Writing.
VI. Files generated from Appointments > Letter Writing will be saved to UserData > LetterTemplate >

CanLetter.

2.19. Spine Utility changes for Birthday & Anniversary images

For Spine Utility configuration file in Admin > Site Admin > Configuration File, below changes has
provided :

Figure 51

I. Image upload option provided for Birthday,Marriage Anniversary and Work Anniversary as shown in
below Figure. Uploaded images will get saved in path : HRMSApp/AdminDataFiles/SpineUtilityImage/
II. In SpineUtility.exe.config image related info will not be stored.

2.20. Secondary Approver Validation

Secondary Approver Validation is provided for Modules in which Primary and Secondary approver can
take action.

Validation is provided to verify Primary and Secondary Approver. Validation is done Module wise. If
Employee used as primary approver for one module is again used as secondary Approver for the same
module at any level then Apply, Approve, Apply By Manager for that module will get Error message for
the employee.
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e.g Emp. Code 1 has Primary Approver 1:Emp Code 2 and Primary Approver 2: Emp code 6 for
Leave .Here Emp code 2 and 6 cannot be used as secondary approver for same employee .
Same Validation is provided in Mobile as well.

2.21. Manager desk - Web Statistic Implemented

Web Statistics Report will be generated in Admin - > Reports- > Web Statistics as shown in below fig:

Figure 52

Web Statistics Report will be generated if user visits the Manager Desk for Following menus.
I. Self Service --> Workflow --> MyWorkflows --> Manager Desk
II. Self Service --> Confirmation --> Approve --> Manager Desk
III. Admin --> HR Activities --> Employee Track
IV. PMS-->Appraisal by Manager

2.22. Ask for Consent of use for Cookies

Consent for use of Cookies will be asked as shown in below figure:

Figure 53

On login page popup will be shown to accept cookies. If user dosen't accept it then he wont be allowed
to login.
A popup will appear only once for every device (browser) and consent will be taken and saved in cookies
of browser.
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2.23. Userdata Path Locked for SAAS Client

Userdata Path are provided in Admin - > Site Admin ->Site Admin -> Other Web Settings, as shown in
below Figure:

Figure 54

Below setup textboxes will be locked for SAAS Client.
i. (Web) Documents Path
ii. (Mobile) Documents Path
iii. Changes in setup Mobile In/Out on approval basis ( by attendance workflow)

2.24. New Setup ChatBot CustomMessage for not found Queries

ChatBot Custom Message HTML Editor is provided in Admin -> Standard Setting as shown in below
Figure:

Figure 55

I. New Setup provided as ‘ChatBot CustomMessage for not found Queries’.
II. HTML Editior (2000 chars) is provided.
III. Current message (I can not match your requirement, do you want me to search globally. / Yes / No

button) is shown in HTML editor by default
IV. User can define customized message for Not Found Queries using this option.Newly defined

message will be shown if Spina is unable to find the result.
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2.25. More then one LDAP server can be configure license wise

LDAP Server count will be stored in key:e.g.LDAP Server 2 license is purchased then ID S1,S2 can be
defined by Admin login. While login validation will be based on server(same as existing working of LDAP).

2.26. Allow Uploading ZIP / RAR File setup working provided all over
software

‘Allow Uploading ZIP / RAR File’ is present in Standard Setting - > Other Web Setting, as shown in below
figure:

Figure 56

Allow Uploading ZIP / RAR File setup working provided all over software.If this option is opted then All
over software ZIP/RAR file will be allowed to attach.

2.27. SMS Template Changes

In the SMS notification template below details will be shown in every macro:
1) @@Login URL
2) @@Company name
e.g. On Leave Approve SMS will be sent as @@CompanyName - Your Leave from the period
@@fromdate to @@todate has been @@AppStatus. You can check by login with this link @@Loginurl

Demo Company - Your Leave from the period 06-Sep-21 to 09-Sep-21 has been Approved. You can check
by login with this link Please do login with https://team.spinehr.in/login.aspx

2.28. Pending Mobile Mark In/out details in Email for Managers

In Site Admin > Reminder Email to Employee/HR -> Workflow Mail Settings existing option"Send daily
reminder to Manager for pending list of application to be approved" is available,as shown in below
Figure:

https://team.spinehr.in/login.aspx
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Figure 57

If it opted then Mobile Mark In/Out details will be displayed in Email to Managers (as per Attendance
Workflow) which are pending for approval, as shown in below Figure:
Also other pending applications i.e Leave, expense etc will also display in email as per existing working of
setup.

2.29. Filters provided for Organization Chart

Filters are provided for organization chart in Self Service -> Workflow->Organization Chart, as shown in
below figure:

Figure 58

In Organization Chart, below filters are provided to view chart :
I. Direction : 2 options Upward and Downward provided.
II. Employee filter : Employees which are added in Admin -> Organization chart will be displayed here.

As per selected direction and Employee, organization chart will be displayed.
Note : This feature is available for SQL backend only.



New Features of Spine HRMS Version 6.0.3

39

2.30. Secondary Approver provided for Request Deskmodules

I. Secondary Approvers are now available for Request Desk module and Request Desk_001 to Request
Desk_015 modules.

II. "Send Email to Manager(s) of same stage for action(Approved/Rejected) taken by other Manager'
option is provided inMore -> Request desk settings, as shown in below Figure :
For e.g. at approver level L1 primary approver "A01" and secondary approver "A02" is assigned for
Request desk and its modules then after approving/rejecting request by approver "A02" email will
get sent to "A01" and vice versa.

Figure 59

2.31. Asset Code added in Asset allocate import

“Asset code” field is provided for Asset Allocate import in Admin -> HR Activities > Assets Entry - Allocate
Assets to allocate asset as per asset code and asset name wise to employee, as shown in below figure:

Figure 60
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2.32. New Setup provided for GCC Details Tab and Saudi Information
Tab

New setup is provided in Admin > Std Setting > Self Service Settings, as shown in below figure:

Figure 61

New Options provided in Std Setting > Self Service Settings :
I. Show GCC Details Tab ( Only When GCC License )
II. Show Saudi Information Tab ( Only When Saudi Information License )

If this option is selected then only Self Service -> View -> Employment details will show GCC
Details/Saudi Information tab.

2.33. Setup provided for Visitor and Candidate Info Mobile No.

“Allow Mobile No. length X for edit profile “ setup is present in Admin -> Standard Settings -> self service
settings, as shown in below figure:

Figure 62

Set Up : Admin > Standard Settings > self service settings>'Allow Mobile No. length X for edit profile 'was
working only for Edit Contact.Now it will work for Below modules also:
a : Visitors > Visitor Registration
b : Visitors > Add Appointment
c : Candidate Info > New
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2.34. Date Filters in Manage User Profile & Assign Role

Joining From Date and Joining To Date filter is provided in Admin -> Manage User Profile, as shown in
below figure:

Figure 63

Joining From Date and Joining To Date Filter is provided to Filter the data.

2.35. Export to Excel option provided

Export to Excel option provided in User Management -> Manage User Profile, as shown in below Figure :

Figure 64

User can Export Manage User Profile details from here.
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2.36. Export to Excel option provided

Export to Excel option provided in User Management -> Assign user group Category, as shown in below
Figure :

Figure 65

User can Export Assign User Group Categry details from here.

2.37. Service by option provided in Footer for partner(Key Based)

Service By option is provided in Footer as shown in below figure:

Figure 66

Footer will Show 'Service by' details based on Key.Partner Note tag content will be displayed.

2.38. Test Mail In NewWindow

Changes are done in Admin > SMTP Settings as shown in below figure:
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Figure 67

After Clicking on Test Email pop Up window will be displayed showing
i. From Email
ii. To Email
iii. SMTP Host
iv. Port
v. User Name
vi. Password

2.39. Workflow Related Changes

Changes are done in Workflow Definition,as shown in Below Figure:
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Figure 68

If application is pending with approver then it will restrict user to do any changes in that module’s
workflow definition.When All Applications are final Approved/Rejected then only software will allow to
modify the workflow definition.

2.40. Changes in Active Employee Report and Active Mobile Login List
Report

New Column added in Last Active login field in Web statistics report, as shown in Below Figure:

Figure 69
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Figure 70

New column added 'Last Active Login' in following reports:
1. Admin -->Web Statistics -> Active Employees Report
2. Admin -->Web Statistics -> Active Mobile Login List

It will show Last(recent) Login Date & Time for Employee.

2.41. Filter option provided for Birthday Block View All

Filter option provided for View all list in Birthday Block, as shown in below Figure :

Figure 71
In Birthday / Anniversary List View,Filter Provided with three option : All, Birthday and Anniversary.Using
this data can be filtered.

2.42. Changes in Travel DeskWorkflow Definition

Cut off working provided for Travel Desk,as shown in Below Figure:
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Figure 72
Cut off working provided forTravel Desk . We can configure the Travel Desk workflow 'category wise' like
Expesne module.

3. Self Service

3.1. Display Visa details for Family Member

Family Visa Details will be shown in Self Service ->View -> Immigration, as shown in below Figure :

Figure 73

I. It will display visa details with For ,Visa Name, Citizenship ,Issue Date,Exp. Date, Remark.
II. View is also provided in Mobile.
III. 'Send Email to HR for the list of employees whose visa going to be expire' option available in Admin
->Reminder Email Setting, it will send employee and Employee's Family member visa expiry details to HR.
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3.2. Saudi Additional Information key base

Saudi Information tab is given in Self Service -> View -> Employment , as shown in below Figure :

Figure 74

This new tab will display following details:
I. Iqama Details for Self and Family Member.
II. Aramco Details.
III. Aramco Car Sticker Details.

3.3. Document attachment for Passport and Visa

Document Attachment option is provided for Passport and Visa in Self Service -> View/Edit ->
Immigration/Visa Detail, as shown in below Figure:



New Features of Spine HRMS Version 6.0.3

48

Figure 75 Figure 76

Document will display on approval.

3.4. Passport Entry provided for Family members

Passport entry provided for Family member in Self Service -> View/Edit -> Immigration, as shown in
below Figure :

Figure 77

It will display Passport for Self/Family. On selection of Family, family members will be displayed in drop
down to add passport details.
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3.5. Visa entry is provided for Employee and Family members

Visa entry is provided for employee and family members in Self Service -> Edit -> Visa Details, as shown
in below Figure :

Figure 78

Employee can add multiple Visa details in Self service -> Visa details for self as well family members.
Accepted visa details will be displayed to employee in self service -> Immigration -> Visa Details.

3.6. Edit Driving license info for family members

Driving License entry is provided for employee family members in Self Service -> Edit -> Driving license, as
shown in below Figure :
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Figure 79

Now employee will be able to add family member's Driving License details.

3.7. Family - Emergency Field Changes

Changes are done in Self Service > Family as shown in below figure:

Figure 80

For Emergency Field Checkbox is Removed and Provided Drop down with options (Blank / No /
Yes).Emergency Field is Mandatory i.e. while saving Blank value is not allowed It should be Yes or No
only.
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3.8. Aadhar No provided for Family

Aadhar No field is provided in Self Service > Edit > Family as shown in below figure:

Figure 81
Now Aadhar No can be added for Family member.

3.9. Employee Edit Profile - Photo changes

Changes are done for employee Upload photo in Self Service > Edit > Profile as shown in below figure:

Figure 82

Now Employee will be able to upload Photo upto 1 MB.
Note also provided in pop up window: File size should not be more than 1 MB.
Only jpg, jpeg and png extensions are allowed to upload.
In Self Service > Edit > Profile, Employee Photo can be Added/ Removed and it can be cropped as well.

http://192.168.9.101/zentao/testtask-view-267.html
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3.10. Profile new tab / Add social media link

Social media links (Facebook, Twitter, LinkedIn, Koo) can be added as shown in below figure:

Figure 83

Show/ hide setup given for Social Media Links, In Standard setting > "Employee Profile Page Setup" as
shown in below figure:

Figure 84

Social Media icons and Employee Photo display In employment and Logout Profile Pop up, only those
social media icons enable whose links are provided.

http://192.168.9.101/zentao/testtask-view-267.html
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3.11. Deduction u/s 80TTA added in Investment Entries

New investment entry is added in Self Service -> Taxation -> Add Declaration and add Investment / Claim
Made entry page, as shown in below figure:

Figure 85

Interest on deposits in saving account for Ded. U/S 80TTA is provided.User can add Investment entry for
the same.

3.12. Tax Section Limit Display For PayrollNX Database

Tax Section limit is displayed for PayrollNX Database, as shown in below figure:

Figure 86
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For PayrollNX database Displayed Tax Section Limit on Following pages :
I. Self Service -> Taxation -> Add Declaration
II. Self Service -> Taxation -> Investment / Claim Made List

3.13. Tax Projection display for PayrollNX database

For PayrollNX database 2018 onwards Tax Projection will be displayed in Self Service -> Taxation -> Tax
Projection, as shown in below figure:

Figure 87

3.14. Changes in Tax Projection view

Changes are done in Tax Projection View, as shown in below figure:
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Figure 88

To View Tax Projection, Options are given as New Regime, Old Regime, As per Employee Master for
Desktop and NX Database.User can view Tax Projection using these options.

3.15. Tax Projection PayrollNX DB (Projection as per Web declaration
amount)

"Projection as per Web declaration amount" option provided in PayrollNX Database , as shown in below
figure:

Figure 89
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3.16. Deduction u/s 80TTB is provided in Taxation

New Type of Payment option provided, as shown in below Figure :

Figure 90

“Deduction u/s 80TTB” is provided for Interest on deposits in saving account for Sr. Citizen. Limit of
Deduction u/s 80TTB is 50000.

3.17. Deduction u/s 80GGC is provided in Taxation

New Type of Payment option provided, as shown in below Figure :

Figure 91

Deduction u/s 80GGC is provided for political party donation.Limit of Deduction u/s 80GGC is unlimited
(99999999.00).
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3.18. New Tax Regime for F.Y 2020-21 on optional basis

"Allow employee to modify the Tax Regime" option is provided for F.Y 2020-21 in Admin -> Site Admin
-> Standard Setting -> Tax Projection and Payslip Setting, as shown in below Figure:

Figure 92

If it is opted then "Deduct my TDS as per new Tax Regime" option will be available for employee in Self
Service -> Taxation -> Edit Tax Eligibilty, as shown in below Figure :

Figure 93

I. It will be based on approval where request made by employee can be approved/rejected from
Admin-> Contact/Statutory -> Module : Employee Wise Flag Setting.
II. Email will be sent to Manager if employee made the request for new tax regime as well as email will
be sent to Employee on approval.
III. After approval of new regime, log will be displayed in Reports -> Log of Settings Edit-Updates.
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3.19. Income Tax Slab changes for F. Y 2020-21 with old regime and new
regime

For F.Y 2020-21, new income tax slab changes has provided for “New Regime “as per government
statutory norms in Self Service -> Tax Projection, as shown in below Figure.

Figure 94

I. In case New regime opted then Standard deduction,PT Deducted,salary exemptions,deductions
(Except 80CCD 2), Loss from House property will not be appeared. For Old regime it will be
displayed.

II. For old regime, Income tax for 2020-21 will be calculated as per slab F.Y 2019-20 only.
III. For New Regime, in case any exemption need to display then same can be done from Perks and

investment entry using Type of payment : Exemption. For old regime it will not display in tax
projection.

IV. For old and New Regime, Rebate will be 12500 for employee taxable total income is between 2.5L
to 5Lakh.

3.20. GCC details display provided in Employment (Client opted for GCC
key)

In Self Service -> View -> Employment, “GCC details” tab will display for client who have opted for GCC
key licence.
It will display details as per GCC details available in PayrollNX -> Employee Master -> GCC tab.
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3.21. PAN No. format validation for Lender and Landlord

“PAN No. format validation” is provided for lender and landlord in Taxation for Type of Payment :
Housing Loan Interest Payment (as Loss) and Rent Paid (For HRA Exemption), as shown in below Figure:

Figure 95

Validation is provided in Self Service -> Taxation -> Add declaration/Add Investment/Claim Made/Submit
Tax Declaration - sheet.
PAN No. Format will be validated based on Spine Payroll setup available in Utilities -> Payroll Standard
Setting -> Form 16 options :
I. Do Not Check PAN Number format for Lender
II. Do Not Check PAN Number format for Owner

3.22. New Setup provided in Exit Mgmt Setting for Last working date

'Do not allow to modify last working date' setup is provided in Self Service > Exit Mgmt Setting as shown
in below figure:

Figure 96
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'Do not allow to modify last working date' setup is provided.If this is opted and notice period days are
defined in Payroll Grade Master, then employee can not edit Res. Proposed Date and Last Working
Date.(Dates will be auto calculated).

3.23. Degree can be added by Employee for Payrollnx DB

Degree can be added by Employee in Edit > Qualification as shown in below figure:

Figure 97

For NX Database, Editable Dropdown is provided.
Employee can add the degree if its not available Same like university.

3.24. Tax Projection for new joinee without salary process

New feature added in which new join employee can view tax projection in Self Service-> Taxation -> Tax
Projection, as shown in figure :

Figure 98

Tax Projection will display as per employee joining date. There is no need to process salary and publish
payslip for new join employee to view tax projection in HRMS.
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For existing employee, it will work as per existing functionality I.e Tax projection will reflect for April
month and for May onwards it is necessary to generate and publish salary slip in HRMS.

3.25. Download Form 16 separate menu provided in Taxation

“Download Form 16” new menu provided in Self Service -> Taxation -> Download Form 16, as shown in
below figure :

Figure 99

It will display Form 16 Part A and Part B for downloading as per Form 16 pdf files kept in respective
folders on server.
Note : Earlier Form 16 were available in menu Download Tax Projection.

3.26. View Details option is provided

View Details option is provided in Edit > Contact, as shown in below figure:

Figure 100

Previously in Edit > Personal, Edit > Contact, Edit > Immigration, Edit > Driving License after submitting a
request user was not able to see what details he has entered.Now User can see the details entered as
shown in below figure:
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Figure 101

3.27. Investment Types added in taxation sheet

New Investment types are provided in Taxation > Submit Tax Declaration - Sheet, as shown in below
figure:

Figure 102

Following is added in Taxation > Submit Tax Declaration - Sheet
I. P.T. Paid by employee
II. Deduction U/S 80CCF
III. Deduction U/S 80GG
IV. Rajiv Gandhi Equity Saving Scheme 80CCG

3.28. Asset Serial Number

Asset serial number field provided in Self Service -> View -> Asset List, as shown in below figure:
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Figure 103

Asset Serial number which is updated at the time of asset entry will be reflect in asset list.

3.29. Previous Employer Form16

Attachment option is provided to attach previous employer form 16 in Self Service -> Taxation ->
Previous Employer Form 16 as shown in below figure:

Figure 104

Attachment option is non mandatory field. Once details submitted by employee it cannot be edited.
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3.30. Email Notification for Confirmation Extension

‘Send Email to All Manager if Confirmation date is extended for the Employee Under him/her ’ setup is
provided in Self Service > Configuration > Confirmation settings,as shown in below figure:

Figure 105
If this option is opted and employee’s confirmation request is rejected by any manager from workflow
then Email will be send to all manager in Workflow with Extended date.

3.31. Email Template Change for confirmation Module

Changes are done in Email sent from Self Service -> Request By Manager , as shown in below figure:

Figure 106

Email Template is changed if confirmation request raised from level 1 on behalf of employee.
New Email will be sent as shown in figure.
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3.32. New setup provided for Revoke Resignation

‘Do not allow employee to revoke resignation request after approval’ setup provided in Self
Configuration > Exit Mgmt Settings, as shown in Below Figure:

Figure 107

If this setup is opted then Employee can not Revoke Resignation application after Approval.

3.33. Filter provided for Resignation Approve

Filter is provided for Resignation Approve,as shown in Below Figure:

Figure 108

Previously Resign Status Dropdown was having values:YES/No.Now Resign Status dropdown will show
Pending/Approved/Rejected/All.Also in List View Status column is added for the same.

4. Leave

4.1. Leave Application ID display

Leave Application ID is displayed, as shown in below Figure:
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Figure 109

Leave Application ID is displayed in following pages:
I. Leave/OD/CO+ apply detail and list view.
II. Leave/OD/CO+ approval page in detail and list view.
III. In Leave related Emails of Employee & approver .
IV. Leave application List report HR/ Manager

4.2. New Setup in Leave Setting

"Do not show Employee Leave Balance(s) to Manager while Approving Leave Application" option is
provided in Leave -> Configuration -> General Settings, as shown in below Figure :

Figure 110

If this is opted then while approving leave application, leave balance of employee will be hidden for
Manager.
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4.3. Setup for Check Leave Balance for Full Year

New set up "Consider future Leave balance while generating Monthly Summary" is given in Leave ->
Configuration -> Settings -> “Leave Application - General Settings”, as shown in below figure:

Figure 111

It will consider full year leave balance (Financial/ Calender) When Monthly Summary Generat

4.4. CO+ Lapsed Report

In Leave > Leave Reports > “Reports - HR/ Reports -Manager”, CO+ lapsed report type display only when
X days set in "Allow to Apply CO- against CO+ date within X days", as shown in below figure:

Figure 112

I. In CO+ Lapsed report records will be display only when CO+ lapsed manually from Attendance
Utilities > MISC Utilities > Compensatory Leave Accrued (CO+) Lapsed Utility
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II. In CO+ lapsed report following details display i.e.Employee Code, Employee Name, CO+ Date,
Remark.

4.5. Required Leave Application Intimation Settings for CO-

Now, CO- leave type also available In Leave > Configuration > “Settings - Leave Application Intimation
Settings” as shown in below fig :

Figure 113

4.6. New Leave Report

New Report is provided in Reports > Reports - HR, as shown in below Figure:

Figure 114
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In Leave Reports > Reports - HR, New report available "Leave Approved List Report" as below format :
i) Date Range, Standard Filter, Multi Group Filter available
i) Only Approved Leave Applications will be display.
ii) Records will be Ordered by Employee Name.
iii) Only Spine type Leave will be display in report.
v) Any Leave setup will not be considered in this Report.
vi) Date format will be dd-MMM-yyyy.
vii) For Cross month leave application - filter data based on from date.
viii) For Multiple application in selected date range present then it will display multiple dates with

comma separated.
e.g 05-May-2021 to 06-May-2021, 10-May-2021 to 12-May-2021

4.7. CO+ lapsed utility

CO+ lapsed utility is provided in Time -> Attendance Utilities -> MISC Utilities -> Compensatory Leave
Accrued (CO+) Lapsed Utility for CO Un-utilized leave by employee, as shown in below Figure :

Figure 115

In Leave settings "Allow to Apply CO- against CO+ date within X days" setup is available. By this setup if
CO+ is not utilized within X days then it becomes unavailable to user while applying leave but the actual
CO+ balance is not reduced which creates confusion to Employee.
To reduce it from balance CO+ Lapse utility is provided.
Note :
I. HR can delete CO- adjustment records from Leave -> Leave Adjustment -> Entry.
II. In case of deletion CO+ will be available to employee for consumption as per setup days.

4.8. CO+ Type provided in instance setting

New setting added for CO+ under Leave-> Configuration-> Settings->Leave Settings Type: Leave
Application instance setting, as shown in below figure:



New Features of Spine HRMS Version 6.0.3

70

Figure 116
Instance setting for CO+ will be work same as per functionality available for other leave types.

4.9. Sandwich Rule for Half day present

New setup provided in Time > Configuration > Attendance Settings > "Do Not Consider Sandwich Rule, If
Employee Present For Any Half Day". As given in below figure:

Figure 117

If above setup is tick then it will not mark WO/PH with leave type if employee is present for half day.
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4.10. Auto Mail Alert for Future Planned Leave

Changes are done in R6 Utility as shown in below Figure:

Figure 118

Mail template heading for R6 utility mail changed from Daily Absenteeism / OD Report to Daily
Absenteeism / OD Report / ON GOING LEAVE Report.

Grade,Unit,Category,Department,Designation and Employee Code additional column provided in R6
utility Email: Daily Absenteeism/OD Report/ON GOING LEAVE Report and FUTURE PLANNED Email.
also other columns changed.

Daily Absenteeism/OD Report/ON GOING LEAVE Report Email New columns are:
Sr No. |Employee Code| Employee Name| Location |Grade| Department |Designation| Division |Unit|

Category| From Date| To Date| Total Days |Day Type |Status (Approved/In Process)

Future planned Leave Email New columns are:
Sr No.| Employee Code |Employee Name| Location| Grade |Department| Designation| Unit |Category
Leave From |Leave To |Total Days |Leave Type| Status

4.11. Designation column added in Others position

Designation column is added in Leave->Approve,as shown in Below Figure:

Figure 119

5. Time

5.1. Pagination Provided inWeekly Off

Pagination is provided in Define - > Weekly Off as shown in below Figure:
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Figure 120

Show:50/100/200/250 entries drop down is provided.Default 100 entries will be shown.

5.2. Changes in Attendance Group

Changes are done in Define -> Attendance Group as shown in below Figure:

Figure 121

If 'Convert OT to CO+ on approval bases' setup from Attendance Settings is not opted then also user can
add/Import Attendance Group.Full Day Hours and Half Day Hours Fields Will not be available in such
case.

5.3. New Setup ‘Display My Attendance as per the date range selection’

‘Display My Attendance as per the date range selection’ setup is provided in Time ->Attendance Settings
as shown in below Figure:
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Figure 122

I. New setup provided as ' Display My Attendance as per the date range selection (untick by default)'
II. Above setup will work only for self (i.e. Date range selection will not available for HR and Manager

pages.)
III. If setup is opted then from date and two date selection will be provided and month year selection

will be hide.(difference between two dates can not be more than 31 days)
IV. Data will be shown on change of from date and to date. Refresh button also provided.
V. If date selection is valid then dates will be saved in cookies and on next visit will be filled from

cookies

5.4. Employee code after employee Name In View Attendance

Employee Code will be displayed besides Employee Name filter after selecting Employee in Time -> View
Attendance- HR/Manager for both HR and Manager, as shown in below Figure :
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Figure 123

5.5. NewModule Short Time Off

NewModule Short Time Off is provided in Time -> Short Time Off, as shown in below Figure:

Figure 124

I.Apply/Apply By Manager/Apply By HR and Approve menus are provided.Applied by highest level
Manager and Applied by HR applications will be considered as finally approved.

Working:
I. Late Coming

If Minimum swipe is greater than Shift In Time then Late Coming Short Time Off Minutes will be
Reduced from Minimum Swipe.if it is greater than shift In time then system will add new swipe.if it
is less then or equal to shift In time system will add swipe same as shift In Time.
e.g for Shift time is 9.30 AM -6.30 PM

1) Actual In Time is 9.45 and Employee has Approved late time as 10 minutes then In time will be
marked as 9.35.
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2) Actual In Time is 9.45 and Employee has Approved late time as 20 minutes then In time will be
marked as 9.30.
In case of Multiple entry for same date it will sum minutes for Late coming and then it will reduce
fromMinimum in time.

I. Early Going
System will check Maximum Swipe for requested date when Maximum swipe is less than Shift Out
Time then System will Add Early Going Short Time Off Minutes to Maximum Swipe.After Adding
Early Going Short Time Off Minutes if it is greater then or equal to shift out time then system will
add swipe same as shift Out Time.
e.g for Shift time is 9.30 AM -6.30 PM

1) Actual Out Time is 6.15 and Employee has Approved late time as 10 minutes then In time will be
marked as 6.25.

2) Actual Out Time is 6.15 and Employee has Approved late time as 20 minutes then In time will be
marked as 6.30.
In case of Multiple entry for same date it will sum minutes for Early going and then it will add to
Maximum out time.

II. Break Between working Hours
System will Insert Out punch for From Time (if greater than shift in time)and In Punch for To Time (if
Less than shift out time)
e.g for Shift time is 9.30 AM -6.30 PM
If Short time off is applied for 01.15 PM - 2.00 PM then Out time as 01.15 PM and In time as 2.00PM
Punches will be marked.

Report HR and Report manager menus are provided as shown in below figure
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Figure 125

Figure 126

In update pending application also Short time off module is provided.
Count is shown for self and Manager on dashboard
Application Status Count - Report also shows Short time off module
Spine Utility working for Application Lapse is also provided.

Data deletion Menu is provided as shown in below figure:
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Figure 127

Figure 128

Finally Approved records are shown here and can be deleted.
Recalculation is required For Impact of Short Time Off.

Short Time Off Settings are provided as shown in below figure
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Figure 129

Figure 130
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i. Show following request type(s) while adding Short Time Off Entry (Late coming /Early going /Break
between Working Hours) : Option selected here will be shown to employee belonging to that
attendance group while adding Short Time Request.

ii. Allow for Today:Allow Short time off request for current day
iii. Allow for Past Day:Allow application for last x no of days
iv. Allow for Future Days:Allow application for future x no of days
v. Do not allow Short Time Off on following days:Restrict application for specific day e.g. Monday
vi. Do not allow Short Time Off between Dates:Restrict application for selected date range of every

month
vii. Instance / Minute(s) Limit(Daily/Monthly/Yearly):User can set Instance or minutes limitation for

Day/month/Year as per requirement.Month pattern can be month or attendance cycle and year
pattern can be Calender or financial.

5.6. Capture body temperature in Daily Attendance System

“Body Temperature” will be captured in Attendance System by adding entry or Importing attendance
data. To capture body temperature, setup is provided in Time -> Attendance Setting (Attendance and
Leave Rule Settings) as mentioned below :

Figure 131

If this is opted then Body Temperature field will be displayed in below menus :
A)Time -> Attendance -> My Attendance
B) Time -> Attendance -> Monthly Attendance – Manager / HR
C) Time -> Configuration -> API Configuration
D) Time -> Atten.Reports -> Report HR / Manager
E) Time -> Attendance -> Daily Attendance – Manager
F) Time -> Attendance Utilities -> Attendance Muster Advance
G) Time -> Atten.Reports -> DayWise Attendance Muster
H) Time -> Swipe -> Daily Swipe Entry – Manager
I) Time -> Swipe -> Apply By Manager
J) Import Attendance Data
K) Time -> Attendance Utilities -> Recalculation Master
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Figure 132

Maximum permissible temperature : Temperature value can be added from 0 to 120.
I. If setup value entered as greater than 0 then it will validate the above pages. For E.g. In Setup body

temperature value kept as 100.00 then in above menu it will restrict to enter body temperature
more than 100.00.

II. If setup value entered as 0 then it will validate value till 120 in above pages. For e.g. Setup value
kept as 0 then it will restrict to enter body temperature more than 120.00.

Send SMS/Email alert to HR after Maximum permissible temperature recorded
If this is opted then email/ SMS will be sent to Employee having HR and HR_Atten Role. Email/SMS will
be sent when Body Temperature if it exceeds Maximum permissible temperature based on setup in
below menus.:
A) Importing Attendance File (Format 27, 33, 34, 35, 36, 37, 38) with Body Temperature.
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Figure 133

For Attendance Capture API : SMTP setting is provided in Attendance Api for
SpineDailyAttenAPI.exe.config file. (Path : Admin -> Site Admin -> Configuration File.)

Body Temperature email alert :

Figure 134

Note : Incase of multiple punches available for one day with body temperature then it will display
Maximum body Temperature in My Attendance and Daywise Attendance Muster.

5.7. OT application and approved date provided in OT list report

OT application Date and OT Approved Date columns are added in Time -> OT -> Reports -HR/Manager ->
Report Type : OT Request List Report for both Manager and HR, as shown in below Figure :

Figure 135
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OT application date : It will display date on which OT application request made.
OT approved date : It will display date on which OT application request approved by final approver.

5.8. 'Show record(s) for which Swipe date is not updated' option
provided

‘Show record(s) for which Swipe date is not updated ’ option is provided in Attendance Reports ->Daily In
Out Detail Report as shown in below Figure:

Figure 136

If this option is checked then records without swipe date will be displayed in result.
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5.9. Attendance Lost Hour and Effective Hours in report

In Time > Attendance Reports > Reports - HR / Manager > Daily In/Out Detail Report below new options
are provided for both Manager and HR, as shown in below Figure :

Figure 137

I. Calculate Lost Hours : If this is opted then in report Eff. Lost Hrs column will be displayed. It will
calculate and display Outtime - Intime hrs. For e.g. Out punch = 02:30 PM, In punch after that
04:00 PM then Eff. Lost Hrs will display 1.5 hrs.

II. Calculate Effective Hours : If this is opted then in report Eff. Used Hrs column will be displayed. It
will calculate and display Intime - Outtime hrs. For e.g. In punch = 02:30 PM, Out punch after that
05:30 PM then Eff. Lost Hrs will display 3 hrs.

Example shown in below Figure :

Figure 138
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5.10. IP Address and Machine name changes in Attendance reports

For IP Address and Machine name in report "Fetch Existing IP Address/ Machine Name" option is
provided in Time > Attendance Reports > Reports - HR / Manager > Daily In Out Detail/Summary Report,
as shown in below Figure :

Figure 139

I. On Fetch Existing IP Address/Machine name, drop-down will displayed to select IP Address/
Machine Name.

II. By clicking on Fetch Existing IP Address/Machine Name, “Allow User to Enter IP Address/ Machine
Name Manually” link and vice versa will be displayed to enter IP/Address/Machine Name manually.

III. Report will be displayed based on selected option i.e. from drop-down selection OR Manually
entered value of IP address/Machine Name.

5.11. Update Alternate Swipe Date for Daily In / Out Records

Alternate Swipe date for In/Out records is provided for attendance in Time, as shown in below Figure :

Figure 140
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1. When an Employee works in a night shift and a day shift due to shift cut-off timing In or Both (In / Out)
punch(s) gets considered in previous day shift. To avoid such scenario we have provided Alternate Swipe
Date.
2. "Assign Swipe Date Manually" setup is provided in Time > Configuration > Attendance Settings under
Attendance and Leave Rules Settings. If this is opted then system will consider In / Out entry for
Alternate Swipe Date.
For. e.g. Due to night shift cut off time, for punch 11PM of dated 08-dec-20 swipe date displayed as
07-dec-20 hence it is considering Actual in/out time for 07-dec-20. Here we can apply alternate swipe
date from 07-dec-20 as 08-dec-20 to consider actual in/out time correctly for date 08-dec-20.
Note :
In Attendance Setting “Do not consider records for which swipe date is assigned” and new option "Assign
Swipe Date Manually" these option can be opted simultaneously.

5.12. Avoid deletion of mobile punches

In “Time > Attendance Utilities > Data Deletion”, New option provided "Do not delete Mobile punche(s)".
By default this option opted. With this option if data delete then Mobile punches not deleted.

Figure 141
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5.13. 'Do not Require HR Approval for OT' setup is provided

‘Do not require HR approval for OT ’ setup in Configuration ->Attendance Settings is as shown in below
Figure:

Figure 142

If this setup is opted then After approval by highest level Manager, same values will be copied to HR
values and application will be considered as finally approved.

5.14. Cut Off Time set up challenge

In Time > Configuration > “Attendance Settings”, new setup provided "In Express Daily Calc., Allocate
Auto Shift based on In time" as shown in below fig:

Figure 143

e.g. i) If employee has assigned day shift 08:00am to 08:00pm and cutoff 07:30am, Employee In time
08:00am to 08:00pm again login 08:02pm to next day 08:05am then it will be consider total working
hrs 24:05 as he logout next day morning.

ii) If employee has assigned night shift 08:00pm to 08:00am and cutoff 06:30pm, Employee In time
08:00pm to 08:05am again login 08:06am to 08:06pm, in this case next day In time not captured by
software but by using new set up, for next day it will assign morning shift to employee which is
available for auto shift.

5.15. Remark option provided in Import Daily Attendance

Remark option is provided in Attendance ->Import Daily Attendance as shown in below Figure:
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Figure 144

Remark field is added in all Import Daily Attendance Formats.Remark uploaded will be shown in
Attendance Reports > Reports - HR > Daily In Out Detail Report>Employee Remark column.(Column was
already present).

5.16. Company selection filter provided

Company Filter is provided in Attendance > Muster Generation - HR as shown in below Figure:

Figure 145

Company Name filter is provided in standard filters.Using this filter user can filter data company wise.

5.17. Lock data identification

Attendance data will be visible with gray back-ground colour which are locked,as shown in Below Figure:

1. Time-> Attendance->My Attendance:
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Figure 146

2. Time-> Attendance->View Attendance-Manager

Figure 147

3. Time-> Attendance-> View Attendance- HR
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Figure 148

5.18. Flag filter provided

Flag Filter is provided in Time->Attendance Utilities-> Mark-Revoke InOut as X, as shown in below Figure:
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Figure 149

Data can be filtered using this Flag Filter.

5.19. In /Out/ X marking facility for HOD

Newmenu added for HOD to mark In/Out/X, as shown in below figure:
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Figure 150

A manager(HOD) can do the same functionality like HR with his own workflow.

5.20. New Setup provided

New setup is provided in Time->Configuration > Attendance Settings, as shown in below figure:

Figure 151
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"Save Swipe Employee Remark in Attendance Muster" option is provided in Attendance Setting. If it is
opted then Swipe Request Employee Remark for approved applications will be displayed in My
attendance, View Attendance-HR/Manager, Muster Report Writer etc.
Note :This will display employee remark of maximum IN/OUT time found during the shift. e.g.10am &
6pm then 6pm remark will disply, if night shift then next day out punch remark will be consider

5.21. Day lock while shift change/roster upload

Day Lock Entries will not be Editable in Shift->Bulk Transfer By HR, as shown in below figure:

Figure 152

While Daylock, dates will be disabled for HR and Manager In following pages and note is also provided
i) Time > Shift > Roster - HR / Manager
ii) Time > Shift > Bulk Transfer By Manager
iii) Time > Shift > Transfer By HR

5.22. Allow OT request after rejection in Apply by Manager-Bulk

"Show date(s) for which OT Request(s) Rejected" option is provided in Time -> OT > Apply By Manager -
Bulk, as shown in below figure :
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Figure 153

If it is opted then it will display Rejected OT request in list view. Manager can apply again incase OT
request is rejected.

Figure 154
Earlier rejected OT request can applied from OT -> Apply and Apply By Manager - Single, now it is also
available in Apply by Manager- Bulk.
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5.23. Newmaster-wise Attendance Reports

Two new master-wise reports provided for attendance in Time module:
I. New Report Type : "CostCenter Wise ShiftWise Head Count Report" is provided in Time -> Shift->
Report-HR, as shown in below Figure :

Figure 155

It will display employee count which is assigned to Shift (in Roster or Transfer by HR) for selected date
based on master selection. Incase shift is not allocated to employee for selected date then it will display
count in "Out of Shift".
II. New Report Type: "CostCenter Mandays/OT Report" is provided in Time > Attendance Report >
Analysis Report, as shown in below figure :
It will display master name wise summary data for selected period with Man Day(s), Man Hours, OT
date wise.

Figure 156

a) Man Days : Mandays will be displayed as (Manhours-OT)/8 for particular date.
b) Man Hours : Total Working Hours whose Total working hrs >0 AND Day type : DP,WOP,PHP will

be displayed.
c) OT :Total OT for particular based on will be displayed for respective date.
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5.24. Changes in Short Time Off Email content

Changes are done in Short Time Off Email Content, as shown in Below Figure:

Figure 157

If 'Send Email to the Employee on Short Time Off application Approved / Rejected' setup is opted then
Email content will contain Emp Name and Emp Code. e.g Now Email will get sent as 'Short Time Off
request of Purvika Aman Sharma - 1 for the date 22-May-20 has been Approved'

5.25. Designation Master is added in Muster ReportWriter Grouping

Designation Master is added in Muster Report Writer Grouping, as shown in below figure:
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Figure 158

Report will be shown as per selection taken in 'select group' and filter options.
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5.26. Shift Based Filter as per attendance group(Key Based)

New setup added ‘Consider attendance group shift mapped with employee while shift selection’ in
Time-> Configuration ->Attendance Settings, as shown in below figure:

Figure 159

Two new menus are added under Time -> Define -> Attendance Group as shown in below figure:

Figure 160

1. Assign Shift To Attendance Group :
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Figure 161
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Figure 162

2. Assign Shift To Employee:

Figure 163
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Figure 164

If option ‘Consider attendance group shift mapped with employee while shift selection’ is opted then
below functionality will work.
I. Only restricted / allocated shifts in drop down will be available during Roster-Manager, Roster-HR,

Bulk Transfer By Manager, Transfer By HR and Shift Change Request.
II. In Import Roster and Import Roster Manager only those shift records will upload which are mapped

with attendance group or with employee.
III. If client has opted Auto Shift utility then only those shifts will be assign which are linked with

attendance group or with employee.
IV. Particular shift will be allocated to Attendance Groups or Shift Groups. One shift can be allocated to

multiple Groups.
V. Employee will be allocated to particular Attendance Group or Shift Group & even particular individual

Shift.

5.27. Filter option provided for OT Approve By HR

New filter provided on front page in the form of drop down list with all available legend options as
shown in below figure:

Time-> OT-> Approve by HR
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Figure 165
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All legend options which are available In drop down list are as follow:
I. All
II. Muster Generation Entries
III. Daily Attendance Muster And OT Approval Entries
IV. OT Approval Entries
V. Locked Entries (Already Approved)
VI. Locked Entries(Day Locked)

5.28. Weekly Off Import option

‘Import Weekly Off’ is provided to upload weekly off through file in Time->Weekly Off, as shown in below
figure:

Figure 166
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Figure 167

User has to prepare file as per given file structure format and import the same.

5.29. New Option provided in Shift Definition

New option provided in Shift Definition in Time->Shift Definition, as shown in below figure:

Figure 168
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In shift definition,new checkbox is provided as 'Consider This Shift For Hour Based Working And Add
In/Out Punches Through Utility As Per Shift CutOff Time'.If this opted then NewMISC utility is provided
to update the InTime and OutTime of Employee in Time->MISC Utilities.

5.30. New MISC Utility provided as Update InTime OutTime Based On
Shift CutOff Time

NewMISC Utility is provided in Time->MISC Utilities, as shown in Below Figure:

Figure 169

Utility will Execute For Employees :
I. With Card Punch Setup:Twice Required ,Where Day is Unlocked and At least One punch is present for

the Day(In/Out/Z).
II. With Assigned Shift for the Day has setup "Consider This Shift For Hour Based Working And Add

In/Out Punches Through Utility As Per Shift Cut Off Time" opted.
III. With Shift allocated from Shift Roster.(Shift from shift roster or Transfer by HR).

At the time of Running the utility User need to provide minutes between 1-30. After Running the
utility In Punch with- In Time Minutes After Shift Cutoff Time and Out Punch with-Out Time Minutes
Before Shift Cutoff Time will be marked for the day.
E.g. Employee Has Shift [AA] Time: 20-Dec-21 05:01 AM - 21-Dec-21 05:00 AM [As per Cut Off Time] .
In Time Minutes After Shift Cutoff Time and Out Time Minutes Before Shift Cutoff Time are provided
as 02 then In and Out punch for Employee for the selected day will be marked as :
IN 20-Dec-21 05:02 AM
OUT 21-Dec-21 04:58 AM
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5.31. Allow Shift Change Request for same day after approval

Shift change request for same day will be allowed after approval also. But in shift transfer HR there will
be a single record only.

5.32. Day Lock Record indication in Approve Swipe

Day lock record indication is provided in Swipe-> Approve Swipe if day is already locked, as shown in
below figure:

Figure 170

Same lock data indication is also provided in Leave-->Approve menu.

5.33. New setup provided as ‘Manager RemarkMandatory while
Approving/Applying OT Request’

New Setup provided in Time->Attendance setting, as shown in Below Figure:
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Figure 171

New setup provided as 'Manager Remark Mandatory while Approving/Applying OT Request' in
Attendance Setting.
If opted then manager Remark will become mandatory for below menus:
i. OT - > Apply By Manager - Single
ii. OT - > Apply By Manager - Bulk
iii. OT - > Approve

5.34.Attendance Muster Export(Key Based)

New menu is added with name Muster Export Report and Fetch button is provided in Muster export
Report,as shown in Below Figure:

Figure 172
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Figure 173

1 . To copy attendance muster data to Third party database below setup need to configure :
In HRMS -> App Data -> Con.config connection string to be mentioned as "<add
name="AttenMusterExport_ConnectionString" connectionString="[providerPathOf DailyAttenMuster
Database]"/>"
2. Attendance muster data will be copied to provided database in setup and will push data by creating
new table "tblAttenMusterExport".
3. Select Date Range and click on Fetch button once above client service configured.
Note : Data will be pused based on date selection in Expense Muster Export Report. Maximum Days 31
can be selected in date range to fetch attendance muster data.

6. Timesheet

6.1. Email setup for Project Assigned/unassigned to employee

New Email setup is provided for Project Assigned/unassigned to employee in Time -> Configuration ->
Timesheet Setting, as shown in below Figure :

Figure 174
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If these options are selected then while assigning/unassigning Project (FromManage Timesheet ->
Assign Project to Employee/Assign employee to Project) to Employee Email/SMS will be sent to Employee
on their Email ID/Mobile Number.

6.2. Employee Selfie image can be zoom in/zoom out

While approving/rejecting application for Mobile Clock In/Out employee selfie image displayed on
screen can be zoom-in/zoom-out in Time -> Swipe -> Approve Mobile Swipe - HR/Manager.
Note : Earlier setup were provided in Time -> Attendance setting with option name as " Save HD image
from Attendance settings" for image zoom-in/out, now it has removed from setup as default working for
zoom-in/out is provided.

6.3. Mobile Mark-In/out rejection approver remark and email setup.

Approver Remark is provided in attendance In/Out punches on date popup window in below screen, as
shown in Figure :
I. Attendance -> My Attendance
II. Attendance -> View Attendance - Manager
III. Attendance -> View Attendance - HR

Figure 175

When an employee does Clock IN or Clock OUT frommobile & if Approver Rejects the Application with
remark then Approver remark will be displayed in above screen.
2. Email setup is provided in Time-> Configuration -> Attendance Setting under Mobile attendance
setting as "Send Email notification to employee when mobile Mark In / Mark Out is rejected."
If this is opted then email will be sent to respective Employee on their email ID in case approver reject
the Mobile clock-in/clock-out request.
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Figure 176

6.4. Changes in Group Account 2, Group Account 3 wise cost list
Timesheet Report

In Group Account 2, Group Account 3 wise cost list report ,Department column is added in Timesheet ->
Reports, as shown in below Figure:

Figure 177

6.5. Changes in Employee wise Timesheet Details Report

In Employee wise Timesheet Details Report ,Department column is added in Timesheet -> Reports, as
shown in below Figure:

Figure 178

6.6. Changes in Day wise attendance summary Report
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In Daywise attendance summary Report date is added in Attendance Report -> Analysis Reports, as
shown in below Figure:

Figure 179

6.7. NewMenu Project Department Master is provided

NewMenu Project Department master is provided inManage Timesheet -> Project Department Master,
as shown in below Figure:

Figure 180
User Can define Project department using this Menu.Default project Department will be Default added.

6.8. NewMenu Assign Project Department to Employee is provided

NewMenu Project Department master is provided inManage Timesheet -> Assign Project Department
To Employee, as shown in below Figure:
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Figure 181

Assign Project Department to Employee menu is provided with import.Project department named
‘Default’ will be default created and assigned to Employee who were having atleast one project assigned
before upgrade.

6.9. Changes in Project Master

Project Dept. and Project Desc. fields are provided inManage Time sheet -> Project Master as shown in
below Figure:
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Figure 182

Project Dept. and Project Desc. fields are provided. All Project added before upgrade will be assigned
Default department.

6.10. Changes in Assign Project to Employee

Changes are done inManage Timesheet -> Assign Project to Employee as shown in below Figure:

Figure 183
Projects (Assigned/Un Assigned) are shown as per project department i.e. Projects which are having
same Project Department name as Employee's Project Department will be shown.Project department
impact is added in all related pages.

6.11. Changes in Assign Employee to Project

Changes are done inManage Timesheet -> Assign Employee to Project as shown in below Figure:
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Figure 184

Employee (Assigned/Un Assigned) are shown as per project department i.e. Employee which are having
same Project Department as Project’s Project Department will be shown.

6.12. Assign Project to Employee menu provided to Approver

NewMenu Project Department master is provided in Attendance Report -> Analysis Reports, as shown in
below Figure:

Figure 185

Assign Project to Employee menu provided to Approver same as HR.Projects (Both Assigned /
Unassigned ) which are having same project department as employee's Project department will be
shown and approver can assign them.

6.13. New Setup provided as ‘Show Effective Date while filling Time
Sheet’

New Setup ‘Show Effective Date while filling Time Sheet’ is provided in Configuration -> Timesheet
Settings as shown in below Figure:
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Figure 186

If this setup is opted then only Effective date will be available while filling Time sheet.Impact is given in
Mobile as well.

6.14. New Setup provided as ‘Show From Time/To Time while filling
Time Sheet’

New Setup ‘Show From Time/To Time while filling Time Sheet’ is provided in Configuration -> Timesheet
Settings as shown in below Figure:

Figure 187

If this setup is opted then only From Time/To Time will be available while filling Time sheet.Impact is
given in Mobile as well.
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6.15. New Setup provided as ‘Show filled Time Sheet to Manager, Even if
an Employee has not submitted’

New Setup ‘Show filled Time Sheet to Manager, Even if an Employee has not submitted’ is provided in
Configuration -> Timesheet Settings as shown in below Figure:

Figure 188

Figure 189

If this setup is opted then Not submitted timesheets will be shown to manager in Approval page.Such
Not submitted timesheets can be viewed only.

6.16. Application Status Filter option provided in Time sheet

Application Status Filter is provided in Time Sheet > Reports - HR as shown in below Figure:
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Figure 190
Application status dropdown is provided in below mentioned reports with
values:Inprocess/Approved/Rejected.
For following reports this filter is provided:
I. Employee Wise Report
II. Project wise Summary Report
III. Project/Employee wise Summary Report
IV. Time Sheet Hours Vs Attendance Hours
V. Employee wise Cost List Report
VI. GroupAccount1 wise Cost List Report
VII. GroupAccount2 , GroupAccount3 wise Cost List Report
VIII. Date/ Account code wise List Report
IX. TimeSheet Details Report With Manager Remark
X. Employee Attendance Hrs Vs Project Hrs Summary
XI. Employee Attendance Hrs Vs Project Hrs Details
XII. Project/Account code wise Report
XIII. Employee wise Project/Account code wise Detail Report
XIV. Project wise summary Report (pivot)
XV. Date/ Account code wise Cost List Report
XVI. Employee Wise TimeSheet Details Report

6.17. Leave lapse Utility provided

Leave Lapsed Utility is provided on Attendance Utilities -->MISC utilities, as shown in below figure:
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Figure 191

A Setup is provided to Lapse the Leave for past XX days in Leave-->Configuration --> Settings -->Leave
Application General Settings -->Leave Lapse Settings, as shown in below figure:

Figure 192

A Utility needs to be run on daily basis to get accurate result of balances.
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7. Claim

7.1. Assign Default Project Department in Claim

Assign Default Project Department button is provided in Claim -> Assign project/Timesheet-> Assign
Project to Employee & vice versa for Project and employee Project Department is not assigned, as shown
in below Figure :

Figure 193

By clicking on this button Project Department as "Default" will be assigned to Project and Employee.

7.2. Reimbursement changes

Changes are done in Reimbursements -> Apply as shown in below figure:

Figure 194

If Update and Carry Forward is not done for Current Year then Employee can apply for Previous year
Voucher.
If Update and Carry Forward is done for Current Year then Employee can not apply for Previous year
Voucher.Records will be displayed in locked state.
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7.3. New fields added in Expense JV List Report

New Fields are provided in Claim -> Expense -> JV List Report,as shown in below figure:

Figure 195
In Claim -> Expense -> JV List Report below new fields are provided :
1. Voucher Date : It will display voucher date on which expense voucher added.
2. Remark : It will display remark from Expense item.

7.4. Enhancement for Expense module

Enhancement is done in Apply Voucher , as shown in below Figure:
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Figure 196

In Claims -> Expense module for below menu’s Note is provided :
Expense City Type, Expense City, Expense Category, Allocate Expense to Group,Travel Type
Expense Travel Type menu has shifted after menu Expense City Type.
“Allocate Expense to Group” button available in Expense Head will display as menu in Manage Expense.
While applying new voucher entry in Expense -> Apply Voucher, "Save and Submit" button is provided
which will save the voucher and submit for approval directly.

7.5. New Setup User Defined Caption - Transport Type

New Setup ‘User Defined Caption - Transport Type’ is provided in Claim -> Expense Setting as shown in
below figure:

Figure 197

In Expense Setting New setup provided as 'User Defined Caption - Transport Type'.Here user can set user
defined caption for Transport Type.
This user defined name will be shown in Expense Voucher added with option: Claim without travel and in
reports.
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7.6. Expense JV data can push to third party table (key base)

“Copy JV View Data” button is provided in Claims -> Expense -> Expense JV List Report,(client who have
opted this key) as shown in below Figure :

Figure 198

To copy expense JV data to Third party database below setup need to configure :
In HRMS -> App Data -> Con.config connection string to be mentioned as "<add
name="JVData_ConnectionString" connectionString="[providerPathOfJVDatabase]"/>"
JV view data will be copied to provided database in setup and will push data by creating new table
"Tab_ExpenseJVView".
Select Date Range and click on Fetch button once above client service configured.
Note :
I. Data will be pushed based on option "Generate DR/CR Entries for each voucher items" opted in

Expense JV List Report.
II. Maximum Days 31 can be selected in date range to copy JV Data.

7.7. Changes in Copy JV Data

If using 'Copy JV data' button user is pushing data to sql mediator table of expense then GST details like
Vendor Name. Location: GST NO: Gross Amt: IGST SGST: CGST UGST will aslo be fetched.GST details will
be pushed to 'Tab_ExpenseJVView' table.

7.8. Expense category column for approver list in Approve Voucher

Expense Category Column is provided in Expense->Approve Voucher,as shown in below figure:
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Figure 199

“Expense Category” column is provided in Expense while approving voucher for Manager in Claim ->
Expense -> Approve Voucher, as shown in below Figure :
It will display Expense category which is selected by Employee while adding voucher.

7.9. New option provided in Expense JV List Report

New option is provided in Expense> Expense JV List Report, as shown in below figure:

Figure 200

Below New Fields are added:
i. Bank Account Number1
ii. Bank Account Number2
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iii. Custom Field 7
iv. Custom Field 8
v. Custom Field 9

New option provided as 'Seperate DR/CR Amount for each voucher items' .If this new option is selected
then two columns will be displyed in result with name Debit and Credit.Debit Column will display Dr amt
and Credit column will display Cr amt.

7.10. Mail alert for reimbursement voucher rejection

Changes are done for Email Content of Setup Send Email to the Employee on Reimbursement Request
Approved, as shown in below figure:

Figure 201

if setup 'Send Email to the Employee on Reimbursement Request Approved' is opted then Reason for
approval /Rejection is shown in Email with Label Approver Remark.

7.11. Bulk approval option added inWeb Login

Bulk approval option is provided in Claims --> Expense --> Approve Voucher,as shown in below figure:
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Figure 202

Previously in HRMS web login there was no option to select the vouchers in bulk for approval in Expense
module. Now it is provided.

7.12. Name of the Final authorized personnel in Authorized Official.

Changes are done in Print Voucher in Expense->Apply Voucher/Approve Voucher,as shown in Below
Figure:
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Figure 203

Final level Approver name will be displayed as Authorized Official.

7.13. Alert New Setup provided for Expense Duplicate Dates

‘Restrict application for duplicate dates’ setup is provided in Configuration -> Expense Settings, as given
in below figure:

Figure 204

If this is opted and User is adding two Entries for same Date then Alert message will be shown and
application will not be saved.
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7.14. ‘Do not allow future date entries‘ setup changes

‘Do not allow future date entries’ setup is present in Claim -> Expense Settings, as shown in below figure:

Figure 205

Previously It this setup is opted then save Voucher was also restricted.Now it will allow to save future
date expense voucher only submission will be restricted.

7.15. Expense Headwise Attachment option provided

Expense Headwise Attachment option is provided inManage Expense ->Expense Head,as shown in
Below Figure:

Figure 206

Attachment Mandatory While Making Claims' option is removed and Expense headwise 'Is doc
mandatory' checkbox provided.So Expense Head wise Attachment can be made Mandatory or
Nonmandatory.

7.16. New Setup provided as ‘Allow To reapply rejected voucher’
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‘Allow To reapply rejected voucher’ setup is provided in Claim -> Expense Settings, as shown in below
figure:

Figure 207

Figure 208

If this setup is opted then for rejected applications Reapply button will be displayed.
After clicking on Reapply,Application Approval history will be deleted and Application will be shown in In
process mode.User can modify and Submit the same Voucher again.Past history of the approver of
rejection will not be maintained.

7.17. Bulk approval provided for Expense

Bulk Approval selection option is provided in Claims --> Expense --> Approve Voucher,as shown in Below
Figure:
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Figure 209

Using checkboxes provided Approver can select multiple records and Approve/Reject them.

7.18. Changes in Expense Voucher

Changes are done in Expense Voucher,as shown in Below Figure:
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Figure 210

If "Voucher Against Travel" option is used while applying Voucher then below fields will reflect in
Expense Voucher print option:
I. Travel Type
II. From City
III. To City
IV. Travel Location
V. Travel Purpose

7.19. Grade and Branch Master details while approval

Grade and Branch are displayed in Claim --> Expense--> Approve Voucher, as shown in Below Figure:
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Figure 211

Grade and Branch of Employee will be shown to Approver at the time of expense voucher approval.

7.20. Filter provided in Expense Approval

Filter is provided in Expense->Approve,as shown in below Figure:

Figure 212
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In Expense > Approve Voucher>Expense Headwise Details Tab,Filter option is provided.Here User can
Filter data Expense Head wise ,Date wise etc...

7.21. Grade and Designation CC provided in Voucher wise Detail Report

Grade and Designation Masters are provided,as shown in Below Figure:

Figure 213

In 'Show Masters Column options' Grade and Designation options are provided.

8. PMS

8.1. Changes for Confidential Goal / KSA / KRA

For Confidential Goal / KSA / KRA rating and remarks will be hide in Appraisals- > Self / By Manager, as
shown in below figure:
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Figure 214

Because of hide rating, Total rating will not be changed. It consider previous approver rating for
confidential Goal / KSA / KRA so that total rating not affected.

8.2. PMS Enhancement - Goal Category Master Changes

Changes are done in Configuration > Goal Category,as shown in below figure:

Figure 215
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Head Goal Category Filter available for ease of search.
User able to edit Print Order in Grid view.

8.3. Appraisal Calendar changes in PMS

For Appraisal calendar and filters below changes are provided in PMS > Calendar > Appraisal Calendar, as
shown in below Figure :

Figure 216

I. From Date and To date Column will display before Alias Column for Appraisal Calendar.
II. Sorting order by will be in descending for From Date.

8.4. Multiple PMS Category for Goal Library

“Multiple PMS Category” selection is provided in Calendar | Library > Goal / KSA / KRA Library, as shown
in below Figure:
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Figure 217

I. In Goal/KSA/KRA Library multiple PMS category can be assigned. As per assigned PMS category goal
will be displayed to employee belongs to those PMS Category.

II. Increased width for fields Goal Definition and Evaluation Parameter in Goal/KSA/KRA Library.

8.5. Goal by Manager workflowmodule changed to Appraisal Target

Some Changes are done in Goal by Manager, as shown in below figure:

Figure 218
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PMS > Goals > By Managerwill be followed by Workflow module “Appraisal Target”. Employee filter will
display employees for selection as per Manager belong to module Appraisal Target .
Earlier it was following workflow module PMS.

8.6. Self Goal Enhancement

Self Goal Enhancement is done as shown in Below Figure:

Figure 219

In PMS -> Goals -> Self Goal below changes are provided :
I. Task/ Measures, Goal Category, Target Value, Wtg Value, Target Date, Is Proper, Goal Definition,

Evaluation Parameter column wise list will be displayed.
II. Goals added by HR/Manager as well as KSA / KRA for selected Appraisal Period will display in lock

mode and those goal/KSA/KRA type will be displayed Goal-HR/Manager, KSA,KRA likewise.
III. Goals / KSA / KRA which are marked as "Available for Manager" will be displayed in Self Goal with

Goal Definition as 'Confidential', goal Wgt. but goal description will be hidden.
IV. "Restrict goal with total weightage to X%" setup percentage added then Goal Total Wtg and

Remaining Wtg will be displayed in list view of Self Goal. Restrictions on goal weightage will be
validated while adding/approvals of Goals.

8.7. Goal Achievement Summary in PMS dashboard (Key Based)

“Goal Achievement Summary” Report is provided in Admin -> Dashboard -> PMS AND PMS -> Dashboard
Manager for both Manager/HR, as shown in below figure:
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Figure 220

This will display data with target achieved for goals by employee.Goal Achievement summary will display
if Goal library is opted in license key.

Report will display data as below :
I. Summary will be displayed only for Goals added from Goal library.

Figure 221

II. Appraisal Period selection is mandatory. Multiple appraisal period wise as well employee wise data
can be viewed.

III. It will display Goal Achievement report with Goal Code (from goal library), Goal Name (from goal
library), Goal Category, Total Target, Total Achieved, Total Variance.

IV. Show records as per Appraisal Period : If this is opted then Appraisal Period grouping wise data will
be displayed.

V. On click on Goal Code, detail list of Employee Code, Employee Name, Achieved Value, Target Value
and Variance will be displayed on popup, as shown in below Figure :
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Figure 222

8.8. PMS Enhancement - Library for KSA / KRA

In PMS > Calendar | Library > “Goal / KSA / KRA Library” New menu available for Goal / KSA / KRA Library
as shown in below figure:

Figure 223

I. Here all entries display in list view and drop-down filter available for Type (Goal, KSA , KRA)
II. Goal, KSA , KRA type will not be changed on edit records.
II. For KSA / KRA following fields will be hide "Measurement Scale(%, Value,Hybrid)" and "Tracking

Frequency (Daily,Monthly)"

8.9. New Setup Restrict goal with total weightage to X%

New setup Restrict goal with total weightage to X% is provided in PMS -> PMS setting as shown in below
figure:
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Figure 224

I. Changed setup name Validate weightage value as 100% to 'Validate weightage value as 100% while
activating Self Appraisal'

II. Provided new setup "Restrict goal with total weightage to X%" (Provided editable textbox)

X Value can be between 0 to 100 (Integer only)
0 means no validation

e.g
a.if 'Validate weightage value as 100% while activating Self Appraisal' is opted and "Restrict goal with
total weightage to 40% is defined then
User can add Add KRA and KSA of 60 weighatge and Goal-self/HR/mgr1/mgr2 of 40 weightage.
So total will be 100 and Goal total will be 40.
Now go to appraisal calender and change status to ACTIVE FOR APPRAISAL.(existing validation)

b.if 'Validate weightage value as 100% while activating Self Appraisal' is NOT opted and "Restrict goal
with total weightage to 40% is defined then
User can add Add KRA and KSA of any weighatge and Goal-self/HR/mgr1/mgr2 of 40 weightage.
So total will be unlimited and Goal total will be 40.

In PMS Setting "Restrict Goal with total weightage to __%" if any percent updated then while saving Goal
entry by Employee or while approving Goals by manager it will restrict to update Total Weightage of
Goals less than or greater than entered percentage.
Note : Earlier it were allowed to save greater than or less than Total Weightage % with validation
message.

8.10. PMS Enhancement - Appraisal Self - Calendar Lookup Changes

In all over PMS module, Appraisal Calendar lookup below changes given, as shown in below fig:
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Figure 225

I. Column order is changed to FromDt, ToDt, PeriodAlias.
II. If Goal / KSA / KRA marked as "Only for HOD" then Goal description will be hide and Goal Title

display as confidential to Employee and other HOD'S (who are not marked) as shown in below fig:

Figure 226
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8.11. PMS > Goals > By HR/Manager menu split

Goal by HR/Manager is splitted as shown in below figure:

Figure 227

Figure 228

Figure 229

Menus are split into two Parts
a. Goals / Objectives / Feedback
b. KSA / KRA

a. In Goal by HR , Goals added by self and KSA/KRA in lock mode are shown.
(Indication shown for Self Goal and KSA / KRA)
(Indication shown for Self Goal - Inprocess)
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b. Shown Goals Total Wtg and Remaining Wtg in bigger font if setup - Restrict goal with total
weightage to X% is opted.

c. While Adding/Editing goals added validation to validate wtg(Normal and Self Goals wtg) should not
exceed X% as per setup(Restrict goal with total weightage to X%)

Goal By HR Changes are as follows:
a. PMS category is removed from Goal by HR.
b. Appraisal Period, Employee and Type is shown
c. Shown list only when Appraisal Period, Employee is selected
d. In type KSA/KRA are present.If these options are selected then it will filter list but cannot add or delete
them.

3. KRA KSA by HR changes are as follows:
a. Shown List / Type filter same as current working
b. Removed Add Default option from Utility Button
c. PMS Calendar selection will be required while adding data from Goal Library (Provided PMS Calendar
selection in list view screen)
d. Period will not be added while adding manually (Without goal library - current working)
e. ShownWeightage for KSA/KRA

4. Common for Goal by HR and KRA KSA by HR
a. Shown "No Details available" in label (Removed Toaster Message)
b. Shown Weightage above gridview
c. For Select Goal From Library shown goals which belongs to selected PMS category
d. Shifted Import option to Utility button
e. Hide Import option if Select Goal From Library is opted (As user cannot add goals in such case only
select from goal library)

f. Entry form design changes are done
g. Select Goal From Library - popup screen design changes are done.

8.12. PMS Enhancement - Goal Library (Key Based)

Now Goal Library will be key based as below setup will be hide. If key is active then Goal Library will be
active.
Goal Based Task System:
- Allow Employee to Select Goal From Library
- AllowManager to Select Goal From Library
- Allow HR to Select Goal From Library

8.13. Fund Allocation Module - Fund Group

HR will Allocate Incentive or Fund to Manager to distribute among the Manager's Team.
In PMS > Fund Distribution > “Group” here manager assigned for Fund Group as shown in below fig:



New Features of Spine HRMS Version 6.0.3

142

Figure 230

In Utility button there are two options available:
i) Import Fund Group: From here Fund Group will be Import with Group Name and Manager Code.

Figure 231

ii) Assign Fund Group: Fund Group will be assigned to employee From here as shown in below fig:
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Figure 232

8.14. Fund Allocation Module - Batch Master

Batch Master : In PMS > Fund Distribution > “Batch”, HR create Fund Batches with Amount as shown in
below fig:

Figure 233

I. Assign Group to batch: Here Fund Total Amount defined in batches allocated in Fund Groups by HR.
Where Total amount and allocated amount should be equal as shown in below fig:
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Figure 234

II. On edit Assign Group to batch records, Rework button display if any Manager distribute amount to
their group as shown in below fig:
If wrong amount distributed by Manager, then by using Rework button Manager able to distribute
amount to employee again.

Figure 235

8.15. Fund Distribution to Employees
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In PMS > Fund Distribution > “Distribution - Manager” Employee, who assigned as Manager for particular
group will be distribute fund to the batch of employees as shown in below fig:

Figure 236

III. Show already distributed: While select this option all distributed batch details display here.

8.16. Export Fund value to Salary Structure

In PMS > Fund Distribution > “Export Fund Amount” Distributed fund among employees will be exported
to employee's Salary structure in PayrollNX as shown in fig:

Figure 237

In Batch name filter, Only those batch available for export amount which are closed (Fund batch will be
closed when all manager distributed fund among employees).

8.17. Fund Report - Manager / HR:
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In PMS > Fund Distribution > “Reports Manager“ available with Batch Name, Fund Group, Date range,
Employee Filters as shown in below fig. If select Show Closed batch only then in Batch Name filter only
batch display which are closed.

Figure 238

Below three type of report available in Manager page:
I. Fund Distribution List Report: This Report available for Manage and HR both. In this report detailed

Allocated Amount and Remark as shown in below fig:

Figure 239

II. Fund Distribution Summary Report: This Report available for Manage and HR both. In this report
records are grouped by Batch Name and Group Name also display Batch Total and Group Total as
shown in below fig:
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Figure 240

I. Employee wise Summary Report: This Report available for Manage and HR both. Employee wise total
fund display which are going to distribute them as shown in below fig:

Figure 241

In PMS > Fund Distribution > “Reports HR“ , One Extra report available for HR “Fund Allocation Report” as
shown in below fig:
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Figure 242

8.18. Goal Achievement List Report

In PMS > Reports > “Appraisal Reports > Goal Achievement Report” , Goal Report Types available with
two options : Form Report and List Report which have two additional filter of Goal Head Category, Goal
Category as shown in below figure:
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Figure 243

I. In List Report Type, following columns will be display:
Goal Definition, Goal head Category, Goal Category, Target Value, Target Date, Achieved Value,
Variance Value.
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Figure 244

II. In Form report Type, Goal head Category and Goal Category also display in Report.

8.19. e - Records Report Require Filter

In PMS > e - Records > “Reports” , Action Taken Drop-down Filter provided in following reports:
1. Comment List Report
2. Offence List Report

http://192.168.9.101/zentao/testtask-view-170.html
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Figure 245

Goal Category and Goal Head Category Filter is provided in PMS -> Goal -> Goal List Report, as shown in
below Figure :
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Figure 246

Data in report will be displayed as per selected filter.
Goal Head Category column is also provided in Goal List Report.

8.20. NewMenu Re-Initialization By Manager

New menu Re-initialization By Manager is provided in PMS -> Appraisal as shown in below figure:

Figure 247

This will Follow PMSWorkflow. Using this menu Manager can also reinitialize the appraisal process same
as HR.

8.21. New setting provided as Correction Factor for KRA

New setting ‘Correction Factor for KRA’ is provided in PMS -> PMS Setting as shown in below figure:
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Figure 248

Correction Factor for KRA settings is provided.User can enter formula to calculate Correction Factor for
KRA.
PMS -> Scorecard - Correction Factor and PMS -> Scorecard - View Scorecard report will display the value
for the same.

8.22. New setting provided as Correction Factor for Goal

New setting ‘Correction Factor for Goal’ is provided in PMS -> PMS Setting as shown in below figure:

Figure 249

Correction Factor for Goal settings is provided.User can enter formula to calculate Correction Factor for
Goal.
PMS -> Scorecard - Correction Factor and PMS -> Scorecard - View Scorecard report will display the
value for the same.
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9. Recruitment

9.1. QAS form for Interviewer at each level

NewModule selection as Recruitment is added in Admin -> QAS -> “Question Sheet”. As shown in below
figure:

Figure 250

i) Active QAS can be assign while adding Interview Round based on Designation in Recruitment from
Recruitment -> Interview -> “Rounds”. As shown in below figure:

Figure 251

ii) Default QAS display as per saved QAS in Interview Round in Recruitment -> Interview -> “Schedule
Interview”, HR can also modify the QAS sheet selection from here. As shown in below figure:
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Figure 252

iii) In Recruitment -> Interview -> “Schedule by Panel”, link will be provided to interviewer to fill QAS.

Figure 253

iv) Once interview status is Yes from Recruitment -> Interview -> “Schedule Interview“ , then interviewer
can not edit QAS sheet . HR can only view the filled QAS in Schedule Interview List view.

9.2. In Candidate and Vacancy master new fields are added

1. In Candidate Info below new fields are provided Recruitment -> Candidate Info -> new, as shown in
below Figure :

I. Candidate Photo : It will display under Key Information in Candidate Info.
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Figure 254

II. Visa Status : It will display under Personal Details in Candidate Info.

Figure 255

III. Nationality : It will display under Address Information in Candidate Info.

Figure 256
IV. Position Applied, Previous Organization Name : It will display under Reference and Preference's in
Candidate Info.
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Figure 257

V. Department, QID Position : It will display under Reference and Preference's in Candidate Info.

Figure 258

This fields except Candidate Photo are also available for import.
2. In Vacancies -> New Request, Hire Type with Local/Overseas drop-down selection field is provided.

Figure 259

9.3. In Candidate Data List new columns are added.

In Recruitment -> Candidate Info -> Candidate Data List below new columns are provided which will
display data from Candidate info, as shown in below Figure :
I. Position applied
II. Department
III. Nationality
IV. Previous Organization
V. QID Position
VI. Notice period day
VII. Visa status
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Figure 260

9.4. Additional columns are added in Vacancy List Report

In Recruitment -> Vacancies -> Report -> Report Type : Vacancy List Report below additional columns are
provided which will display data as per added vacancy, as shown below Figure :
I. Salary Range
II. Work Experience
III. Education Qualification
IV. Hire Type

Figure 261

9.5. Document selection mandatory and user defined caption for
candidate info

For Candidate Master document below options are provided in Recruitment -> Configuration -> Settings,
as shown in below Figure:
I. Is General setting tab, Document 1 to Document 5 mandatory option is provided. Option name as

"Is Document 1 mandatory", likewise till document 5. If this is opted then Document 1 will be
mandatory for selection in Candidate Info -> New.

Figure 262
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II. In User Define Caption tab, for Document 1 to Document 5 caption name option is provided, as
shown in below Figure. Document 1 to Document 5 name will be displayed in Candidate Info as per
entered caption name.

Figure 263

9.6. JD Report provided in Report-HR

“JD Report” is provided in Recruitment -> Vacancies -> Reports- HR -> Report Type - JD Report for HR, as
shown in below Figure:
It will display JD Code, JD Name, Roles and Skills details added from JD Master.

Figure 264

9.7. Recruitment Enhancement

In Recruitment > Vacancies > New Request/ Approve/ Check Request below changes are done:

I. Details Tab renamed to Vacancy Details.
II. Shortlisted By Column is Removed and direct link given for Shortlisted Candidate by HR, Shortlisted

http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
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Candidate by Requester

Figure 265

III. New tab provided, Vacancy Summary which contains vacancy counts like Applies, Shortlists HR,
Shortlists Requester, Offers, Joins

IV. Good Profiles shows percentages which will be calculate = (no. of Shortlisted candidate by HR/ total
applies)*100, (no. of Shortlisted candidate and total applies count fetch from Vacancy summary tab
of Vacancies > Check request)

Figure 266

http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
http://192.168.9.101/zentao/testtask-view-494.html
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VI. while edit Vacancy details “Vacancy Summary Details block” display. Which is showing count of
Good Profiles, Applies, Shortlists HR, Shortlists Requester, Offers

Figure 267

Note: a) Where Applies shows count of candidate whose applied job for particular vacancy.
b) Shortlists HR shows count of candidate shortlisted by HR for particular vacancy.
c) Shortlists Requestor shows count of candidate shortlisted by Requestor for particular vacancy.
d) Offers shows count of candidate who will be selected in Interview.
e) Joins will be shows count of candidate whose status is joined from prejoin entry page.

9.8. Recruitment Enhancement : Ex-Employee Maintain Records

I. In Recruitment > Candidate > “New”, If candidate is marked as Ex - employee then manager desk
link enable like wise pms module.

II. In employee master, New option provided to map Old Employee Code.

http://192.168.9.101/zentao/testtask-view-497.html
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Figure 268

9.9. LinkedIn Url field provided in Candidate master

New field is provided in Recruitment ->Candidate Info as shown in below Figure:

Figure 269

New LinkedIn Url (optional) field is provided .This is shown in all pages like like Shortlist Candidate,
Schedule Interview, Schedule By Panel,Assign status for selection/Rejection,pre join entry etc where
candidate information page is present.

9.10. Apply by Existing Employee working provided

‘Apply By Existing Employee’ dropdown is provided in Vacancies ->Approve as shown in below Figure:
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Figure 270

I. In vacancy approve 'apply by existing employee' dropdown is provided.
II. 'Apply By Existing Employee' =YES and 'Vacancy Available on Desk'= YES then provided apply button

for existing employee on dashboard (opening block) as shown in Below Figure:

Figure 271

If Employee Clicked on Apply button then Candidate master entry will be created for that employee with
IJP label (Internal Job Posting) and employee can be used for further process as shown in below figure:
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Figure 272

9.11. New Setup ‘Show Rating for Interview Round QAS’ provided

New setup is provided in Recruitment ->Recruitment Setting as shown in below Figure:

Figure 273

'Show Rating for Interview Round QAS' setup is provided.If this is opted then QAS > Question Bank will
show a Rating field for each answer (Maximum 5 digits, Decimal Not allowed).Rating Facility will be
available only for Recruitment QAS.
QAS Form will show rating against each Question as shown in Below Figure:

Figure 274

In QAS popup form
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I. Rating Value will be shown for selected answer.
II. Total Rating for all selected answers will be displayed
III. On save this total rating will be copied to Schedule By Panel>Score Column.Existing Score field is

editable.User can change if required.
IV. If user select this new option then setup 'Maximum score can be given by the panelist while

interview' setup will not work.

9.12. Enhancement in Shortlist by Requester/HR

New changes are provided in Recruitment > Vacancies > Shortlist Candidate - HR/Requester, as shown in
below Figure :

Figure 275

I. While Add to Shortlist/ Remove from shortlist, Vacancy will be updated for candidate in Candidate
info.

II. After selecting Vacancy in Shortlist Candidate - HR/Requester, count will be displayed with Applies,
Shortlist by HR, Shortlists by Requester, Offers & Joins) along with Good Profile (%) for vacancy.

III. List view for candidate records UI & representation enhanced; It will display candidate records with
candidate status, CTC, expected CTC etc with some icon.

IV. Candidate Status, CTC,Expected CTC and Reference By columns will be available for HR Menu only
as per earlier working of Shortlist Candidate - HR

V. Linked In icon will be displayed incase for candidate Linked in URL mentioned in Candidate Info and
linked in url will get open on browser by clicking on Linked in icon.

VI. For existing employee who has applied for any vacancy then indication with "IJP" will be displayed in
Shortlist Candidate -HR/Manager.
9.13.Recruitment Enhancement : Vacancy Visibility toggle
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I. In Recruitment > Vacancies > New Request/Approve /Check request> “Vacancy Details tab”,
Actions bootstrap button provided for Additional information. In Additional information New
options "Visible On Desk", "Apply by Existing Employee" given as shown in below fig:

II. Above options will be modified for records which are Approved, Vacancy Status as Open and (Post
Date + Vacancy to be filled in days) should be greater than or equals to today date.
While Visible and Apply by existing employee is Yes then same vacancy will be visible on main
dashboard with "Apply Now" button for existing employee.

9.14. Import Resume Zip File(s) for candidate

"Import Resume Zip File(s)" provided for Candidate in Recruitment -> Candidate Info -> Import, as
shown in below Figure :

Figure 276

Zip file should contain Resume file name which has mentioned while importing candidate data.
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After uploading resume zip file, resume files will be extracted in Resume folder and as per resume file
name it will displayed in Candidate Info for particular candidate.

9.15. Additional CC Masters provided in Pre Join entry

Division, Unit, Project, Category masters are provided in Appointments > Pre Join Entry as shown in
below Figure:

Figure 277

In Pre-Join Entry Division, Unit, Project, Category masters are provided for selection.After Candidate
Master import in Payroll these masters data will also get import.

9.16. Newmacros added in LetterWriting

NewMacros are added in Appointments > Letter Writing as shown in below figure:
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Figure 278

In Pre-Join Entry Division, Unit, Project, Category masters are provided for selection.
%Division%, %Unit%, %Project%, %Category% macros are added in Recruitment > Appointments > Letter
Writing.

9.17. Changes in Add Salary Info for PayrollNX DB

Flag and Fixed Columns are also provided in Appointments > Add Salary Info as shown in below Figure:

Figure 279

For Payrollnx DB, Recruitment -> Appointments > Add Salary Info > Auto Calculate along with Column
Type at Paytime, flag and fixed are also provided.

9.18. Remark selection mandatory option in Vacancy request

"Set Remark field mandatory in Vacancy Request" option is provided in Recruitment -> Configuration ->
Settings (Vancancies), as shown in below Figure :
If it is opted then Remark will be mandatory while adding vacancy request.
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Figure 280

9.19. Auto populate Confirmation Date in Pre Join Entry

Now Confirmation date will be automatically set on selection of joining date in Pre Join Entry as per
setting available in Payroll application for confirmation date,as shown in below figure:
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Figure 281

For eg. If payroll setting ‘Make employee confirmed after is set as 90 days and while adding pre- join
entry joining date selected as 30th Dec, 2021 then confirmation date will automatically gets populate
after 90 days as 30th March, 2022.

9.20. Import provided for Panel

Panel Import is provided in Interview > Panel as shown in below Figure:

Figure 282

User can import Panel from here.

9.21. Changes in Vacancy Summary Report
One column added with name 'Rejected' in Recruitment --> Vacancies -->Reports HR --> Vacancy
Summary Report which display the count of candidates who are rejected after interview, as shown in
below figure:

Figure 283
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9.22. Letter Writting in PDF Format

Now Letter Writing will be provided in PDF Format in Appointments > Letter Writing as shown in below
figure:

Figure 284

Previously Letter Writing was getting generated in word Format.now it will be generated in PDF Format.

10.Training

10.1. Training Group

I. Training Group menu provided in Training -> Configuration -> “Training Group” as shown in below
fig.

Default Training group already assigned to employee and also Default Group update in Existing Training.

Figure 285

II. Import for Training Group Assign:
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Import for Training Group is provided in Training -> Configuration -> Training Group to allocate Training
Group for multiple employees, as shown in below Figure :

Figure 286

10.2. Training Sub Topic

Training Sub Topic menu is provided in Training -> Configuration -> “Sub Topics” as shown in below
fig.

Sub Topic updated same as Topic Name for only those topics which are already used in Training.

Figure 287

10.3. Add New Training
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Following New fields are added in Training -> Schedule -> “Add” and Visibility of these fields depends on
Training Type and Training Mode selection.
I. Training Type : Induction Non Induction.
II. Training Mode : Online Session and Offline Session
III. Training Sub Topic : Display Sub Topic related to selected Topic
IV. Training Level (1-10)
V. Credit Minutes
VI. Presentation Order
VII. Training Group : Add Multiple groups in a Training
VIII. Training Description
IX. Consent Remark
X. Consent Agree (I Agree, OK, Got It, Completed)
XI. Video URL
On Add Training Screen, While select Training Type Non Induction and Training Mode Online
session then Required fields are display as shown in below figure:
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Figure 288
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I. While select Training Type Induction and Training Mode Online session then Online Content
addition Information section hide.

II. While select Training Type Induction / Non Induction and Training Mode Offline session then
additional fields display i.e. Training Visibility, QAS, Important Dates Section and Venue Section
and Training Level, Credit Minutes will be hide.

10.4. Welcome Session, Online Induction & Training Session:

I. Welcome Session menu provided in Training -> Induction -> “Welcome Session” as shown in below
figure:
In Welcome Session only those training display to Employee, which has Training Mode Offline
Session, Training Type is Induction and if Employee belongs to same Training Group as mentioned in
training.

Figure 289

II. Online Induction menu provided in Training -> Induction -> “Online Induction” as shown in below
figure:
In Online Induction only those training display to Employee, which has Training Mode Online
Session, Training Type is Induction and if Employee belongs to same Training Group as
mentioned in training.

Figure 290
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III. Training Session menu provided in Training -> Course -> “Training Session” as shown in below
figure:
In Training Session only those training display to Employee, which has Training Mode Offline
Session, Training Type is Non Induction and if Employee belongs to same Training Group
as mentioned in training.

Figure 291

10.5. Talent

In Talent Menu following Pages included, which display details same as Self Service -> Skill as shown in
below figure:
I. Training -> Talent -> Skills

Figure 292

II. Training -> Talent -> Skills - Manager
III. Training -> Talent -> Skills - HR
IV. Training -> Talent -> Qualification
V. Training -> Talent -> Qualification - Manager
VI. Training -> Talent -> Qualification - HR
VII. Training -> Talent -> My Training
In My Training, Offline Session and Online Session both training display which is attended by employee.
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Figure 293

I. Training -> Talent -> My Training - Manager
II. Training -> Talent -> My Training - HR

10.6. Online Content

I. Online Content menu provided in Training -> Course -> “Online Content” as shown in below
figure:
In Online Content only those training display to Employee, which has Training Mode Online Session,
Training Type is Non Induction and if Employee belongs to same Training Group as mentioned in
training.

Figure 294

II. In Online Content, Training display as per Training Level and Order by it’s Presentation Order.
Initially Level 1 training display. Once Level 1 Training is completed by user it will be removed from
the list and now Level 2 training will be display in list view.

III. Online Content Detailed view display as shown in below figure:
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Figure 295

10.7. Training Re-Learn

I. Once employee completed Training, It will be removed from Online Content. To view training again
Employee has to make Training Re-Learn Request from Training -> New Training -> “Training
Re-Learn Request”

II. Training Re-Learn Request approved by HR from Training -> New Training -> “Training Re-Learn
Approve”.

III. Now, Employee can again view Training from Approved screen of Training Re-Learn Request as
shown in below Figure:

Figure 296

10.8. Reports
I. HR And HR_Training Role Employee can view Employee’s Offline Session Training Records as per

Training Attendance and Training Status from Reports -> Reports -> “Training History” as shown in
below figure:
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Figure 297

II. In following reports, filter available for Training Type Non Induction, Induction and Training Mode
Online Session, Offline Session. As shown in below figure:

1. Training Report List
2. Training Topic Wise Count Analysis Report
3. Employee Wise Training Report
4. Employee Wise Training Hours Report
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Figure 298

In following reports, filter available for Training Type Non Induction, Induction and Training Mode in
Offline Session only as shown in figure:
I. Training Attendance Report
II. Training Need List Report
III. Training Score Card Report
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Figure 299

10.9. New Column in EmployeeWise Training Report

New columns are added in Training -> Report-HR ->Employee Wise Training Report as shown in below
figure:

Figure 300

In report displayed following fields from Feedback Tab:Interested to Atten, Attended, Feedback.

10.10. Training Awareness email for HOD changes based on group

Training Awareness email notification from “Training -> Schedule-> Add -> Send Awareness Email” will be
sent to only HOD who belongs to Training group specified in added training.



New Features of Spine HRMS Version 6.0.3

182

Figure 301

For e.g. As per above figure, Training Awareness Mail will be sent to HOD (Manager) who belong to
Training Group : Development.

10.11. Feedback enabled for not attended training.

Feedback/Remark field is now enable if Is Attended selected as 'No', as shown in below figure:

Figure 302
Updated Feedback/Remark will be reflect in Training > Training Reports > Reports - HR > Employee wise
Training Report.
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11.More…

11.1. Visitor Management : additional Info

I. Additional Information Button is given inMore -> Visitor -> “Sign In” ,Which is activated while select
record as shown in below figure:

Figure 303

II. Additional information page will be open, once click on Additional Info Button and this page have
COVID 19 information about visitor.

Figure 304
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11.2. Asset Availability Report provided for HOD\HR \Employee

"Availability Report" is provided inMore -> Asset Booking -> Assets Booking By Emp/Manager/HR, as
shown in below Figure :

Figure 305

By this report user can find availability of asset for specific date and time so that asset can be booked
accordingly.
Month wise data will be displayed as per selection in cross tab format.

Figure 306

Same Report is also provided in Assets Booking > Reports - HR as shown in Below figure:
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Figure 307

11.3. Email provided for Discussion Group

After Adding Discussion Topic (Topic status: Open)Default Email will be sent, as shown in below Figure:

Figure 308

After Adding Discussion Topic (Topic status: Open) Default Email will be sent as 'This is to communicate
that there would be a Discussion Forum on Topic as on DATE (DD-MMM-YY)'.
On Edit also Email will be sent.For Discussion Topic (Topic status: Closed )Email will not be sent.

11.4. Travel Type and City Details in Email Notification to Approver

Now Travel Type, From City and To City will be available in Email notification to approver, as given in
below figure:
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Figure 309

11.5. Request Desk Note Provided

Request Desk Note provided in Configuration-> Request Desk Note,as shown in below figure:

Figure 310

Added Note will be displayed at the time of Apply and Approve.
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12.Help Desk

12.1. Query Management Report Changes

‘Query Code’ and ‘Last Reply columns added in Help Desk -> Query Mgmt -> Reports- HR -->Query List
Report as shown in below figure:

Figure 311

In 'Query Code' Query request ID will display.In 'Last Reply' column last reply will be display.
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13.Mobile HR

13.1. UI Changes in Mobile

UI Changes are done in Mobile as shown in below figure:

Figure 312

Home, Setting, Virtual ID, Logout options are moved to footer.Footer is freezed for all pages.Accordion
(Downward Arrow Functionality)removed from Application and Approval tab.
In Footer -> Setting -> Theme Color option is provided with 4 colors.If selected the theme color will
reflect in header, footer and login page only, as shown in below Figure:
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Figure 313

On Home page only Self Service header will be displayed.After clicking on Self Service, application will
redirect to submenu list, as shown in below Figure:
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Figure314

Figure 315

On Home page only Corporate Guidelines header will be displayed.After clicking on Corporate
Guidelines , application will redirect to another page, as shown in below Figure:

13.2. Changes inWork Anniversary Block

Changes are done in Work Anniversary Block, as given in below figure:
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Figure 316

Maximum 5 records will be displayed in given block. If records are more than 5 then ‘View All’ option will
display. On click of ‘View All’ all employee(S) list will display whose work anniversary is on Current Day.

13.3. Changes in Birthday Block

Changes are done in Birthday Block, as given in below figure:

Figure 317

It will display Maximum 8 record of current date in given block. If records are more than 8 then ‘View
All’ option will display. On click of ‘View All’ all employee(S) list will display whose Birthday/ anniversary
is on Current Day.

13.4. Weekly Attendance Block Provided

NewWeekly Attendance Block is provided, as given in below figure:
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Figure 318

It will show last 7 days total hours worked by an employee / Shift Total Hours.
Visibility of Weekly Attendance and My Calendar Block can be managed From Admin -> Site Admin ->
Standard Settings --> My Calendar.
If Calendar “visible” is kept as “Yes” then My Calendar and Weekly Attendance block will be visible on
Mobile Dashboard and if kept as “No” then My Calendar and Weekly Attendance block will be hide from
Mobile Dashboard.

13.5. Redirection to Clock In/Clock Out Page

If User/Employee uses Mobile Application to Mark Attendance continuously for 10 days then from 11th
day onwards system will redirect user to Clock In/Clock Out page directly as given in below figure:
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Figure 319

For 10 days continuation system will exclude Weekly Off and Public Holiday.

13.6. CO+ working for mobile

Now user can apply CO- against CO+ from mobile also. While applying CO-, Drop down is there to choose
CO+ adjustment date.
Below Changes are given in Applications -> Apply Leave -> “Apply”
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Figure 320

13.7. Login Page Logo

Use Login Image path for Mobile login page logo Set up is provided in Setting -> Standard Settings,as
shown in below figure:

Figure 321

13.8. Implement Job ID and Invoice No. for Expense Module - Setup
Based
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If set up “ Show Job ID for Expense entry and Show Invoice No. For Expense Entry” opted then Job ID and
Invoice No. will be display in Application -> Expenses -> “Add Expenses” . As Shown in below figure:

Figure 322

13.9. Currency setup of expense implemented in Mobile

In Mobile Expense, below setup has implemented available in HRMS -> Claims -> Expense Setting.
I. Show currency conversion rate and values : if this is opted then currency conversion rate and value

will display while adding expense entry.
II. Set Default currency Type: While applying expense voucher it will display default currency kept in

expense setting.
III. Lock Conversion rate for default currency : If this is opted then default Currency conversion rate

will be non editable.
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Figure 323

13.10. Dashboard - Vacancy / Opening Block Changes

Mobile Main Dashboard - Vacancy / Opening Block Design Changes are done as shown in below Figure:

Figure 324

Vacancies are grouped location wise in Mobile Dashboard.

13.11. Remember Me in Mobile login

In Mobile HRMS “Remember Me” option is provided on Login page, as shown in below Figure :
It will save login credential for next time login on same machine/browser.
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Figure 325

13.12. Show Atten. Menu in MOB if any of AllowMark In/Out option is
selected

Allow Mark In and Allow mrk Out options are provided in Admin - > Site Admin > Mobile-HR as shown in
below Figure:

Figure 326

If any of the below
I. Allow Mark In : By HR/By Manager/By Employee
II. Allow Mark Out : By HR/By Manager/By Employee
Option is selected andManage User Profile >Mobile Mark In/Out:YES then Atten. Menu will be displayed
to Employee In Mobile.
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Atten. Menu will contain the Sub menu as per Role and Setup opted.

13.13. Shift selection while attendance regularization in Mobile HR

"Allow employee to select Shift while Regularization" option available in HRMS -> attendance setting
implemented for Mobile HRMS similar as Spine HRMS.
If it is opted then while applying Swipe request from Mobile for Type Regularization shift selection will
be available, as shown in below Figure :

Figure 327

I. It will display all shift as per cost center wise (Allow Filter) opted in Shift Definition.
II. b.While applying swipe in-case selected shift does not match with shift available in roster for the

day then it will display message that "Allocated shift (as per roster) and the selected shift for
regularization for selected date are not same." but request will get saved.

13.14. Fence Setup working changes
In Admin -> Site Admin -> Std. Setting -> Setting Type : Mobile-HR for Fence related setup " Allow
Employee to select Fence, while Swipe Punch" changes are done as below :
I. Show all Fence : if this option is opted then HR cannot add fence in Shift Definition -> Define Fence,

Employee can apply Fence request fromMobile HR -> Atten but while clock-in/out approved fence
will be available for selection.
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II. Show Fence as per Shift allocated to Me : if this option is opted then HR can add fence and
Employee cannot add fence but while clock-in/out all fence will be available for selection.

III. Allow Employee to select Fence, while Swipe Punch : If this is not opted then HR can add Fence but
Fence selection will not available to Employee while Clock-in/out.

13.15. Changes in setup Mobile In/Out on approval basis ( by
attendance workflow)

Changes are done in setup Mobile In/Out on approval basis ( by attendance workflow) in Admin - > Site
Admin > Mobile-HR as shown in below Figure:

Figure 328

Previously Swipe with self fence were not available for Approval.If Allow employee to add fence is opted
then Mobile In/Out on Approval basis setup was getting disabled
Now Validation is removed between setup
I. Mobile In/Out on approval basis and
II. Allow employee to add fence
If Mobile ‘In/Out on approval basis ( by attendance workflow)’ setup is opted then all swipe punch with
or without fence will go for approval on setup basis.

13.16. Allow Employee to select Fence setup changes
In Admin > Site Admin > Standard Setting > “HR - Mobile Setting”, "Allow employee to add fence" Set up
Removed. Instead of above setup New Setup provided "Allow Employee to select Fence, while Swipe
Punch" with below two options. At a time only one option will be in use.
I. Show Fence as per Shift allocated to Me - Only that Fence should be display to employee on

following pages Clock In - Clock Out/ Clock In HR - Clock Out HR / Clock In Manager - Clock Out
Manager, which is assigned to employee's Shift.

II. Show all Fence - All Approved Fence (added by employee) and Fence added by HR/ HR_Atten will
display to Employee.
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Figure 329

13.17. Days Count in Calender Summary

Day Count is provided in Dashboard-> My Calender as shown in below Figure:
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Figure 330

Days count is shown beside Attendance Type in My calender.e.g. CL(2)

13.18. Help Desk Module in Mobile HR

Raise Query is provided in Mobile in Application-> Raise Query,as shown in Below Figure:

Figure 331
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Raise Query functionality now provided in Mobile HR, where Employee can make request from mobile.
Reply Query option is provided in Approval->Reply Query, as shown in Below Figure:

Figure 332

Using Reply Query option user can Reply to the Query.

13.19. Location API Changes

Changes are done for Location API, as shown in Below Figure:
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Figure 333
Location Key Vendor Drop down is provided where User can select the Vendor and provided related
Geo-Location Key.Depending on Setup Location Key Vendor will be used for Employee’s Location capture
during Mark in from Mobile.

13.20. NewMenu Approve Mobile Swipe

Previously Approval option to approve punches done through Mobile HR was only available in HRMS,
now same is available in Mobile HR, as given in below figure:
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Figure 334
Approver(HOD) and HR can Approve/Reject punches done through Mobile Clock In/ Clock Out option.
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